Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 3.2 RME : problem with the shadow directory

Hello,

I'm using the RME's shadow directory with a perl script in order to sort and dispatch the archives configuration in other places.This script is working using the DNS names of equipments.

Under CS and RME databases, equipments are displayed with theirs DNS names, so until there it is ok. But when their archives configurations appear into the shadow directory, most of them are displayed with an IP address (wich is not the Loopback0, but an OSPF interconnection address). Weird...

In these conditions, my scripts doesn't work at all.

Someone has an idea?

Regards,

Abel JULIAN,

Nextiraone France.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: LMS 3.2 RME : problem with the shadow directory

Hi Abel,

The Shadow directory contains subdirectories that represent each device class and the latest configurations supported by the configuration archive. Each file name is DisplayName.cfg, where DisplayName is the device's Display Name as defined in the Device and Credential Repository. Each time the archive is updated, the Shadow directory is updated with the corresponding information.

Can you please check few problematic devices in Common Services and click on the Edit Identity tab and see what is the display name of the device.

The point is whatever the display name you have defined in DCR ( Common Services), RME will tend to save the configuration file in shadow directory with the same name.

Thanks
Gaganjeet
4 REPLIES

Re: LMS 3.2 RME : problem with the shadow directory

This is as expected and cant be change.

New Member

Re: LMS 3.2 RME : problem with the shadow directory

Hello,

Thanks for your answer but,

Could you be more precise about this please ? Why this is as expected and why some equipments are displayed with their hostname in the shadow directory ?

It looks like more as a bug as something "as expected" for me.

Regards,

Abel JULIAN

Re: LMS 3.2 RME : problem with the shadow directory

Hi Abel,

The Shadow directory contains subdirectories that represent each device class and the latest configurations supported by the configuration archive. Each file name is DisplayName.cfg, where DisplayName is the device's Display Name as defined in the Device and Credential Repository. Each time the archive is updated, the Shadow directory is updated with the corresponding information.

Can you please check few problematic devices in Common Services and click on the Edit Identity tab and see what is the display name of the device.

The point is whatever the display name you have defined in DCR ( Common Services), RME will tend to save the configuration file in shadow directory with the same name.

Thanks
Gaganjeet
New Member

Re: LMS 3.2 RME : problem with the shadow directory

Thanks Gagangeet for your answers.

I finally found the way to get rid of this. For the equipments that do not appear with their hostname in the shadow directory (even if it is ok in the DCR), I have to delete them from CS and discover them again.

It is ok for me, I close the subject.

Regards,

Abel.

410
Views
0
Helpful
4
Replies
CreatePlease login to create content