Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

LMS 3.2 Topology Services shows incorrect cdp information

Hello,

I notice some discrepances in topology services. For example, hsee-dcn-rack31 (port 1/47) is connect to hsee-dcn-core1 (port 6/37) but the topology services show the port is 6/36. I attach topology services screenshot and cdp command outputs.

What could be the problem?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: LMS 3.2 Topology Services shows incorrect cdp information

Delete them from Topology Services, then perform a new, full Data Collection.

12 REPLIES
Cisco Employee

Re: LMS 3.2 Topology Services shows incorrect cdp information

Nothing was attached.  Was the switch ever connected on port 6/36?

New Member

Re: LMS 3.2 Topology Services shows incorrect cdp information

I have attached files

Cisco Employee

Re: LMS 3.2 Topology Services shows incorrect cdp information

What about the answer to my question?  Was this switch ever connected on 6/36?

New Member

Re: LMS 3.2 Topology Services shows incorrect cdp information

No, this switch has never been connected on 6/36

Cisco Employee

Re: LMS 3.2 Topology Services shows incorrect cdp information

Post SNMP Walks of the cdpCacheTable and ifTable from both devices.

New Member

Re: LMS 3.2 Topology Services shows incorrect cdp information

I attach the snmpwalk outputs.

Cisco Employee

Re: LMS 3.2 Topology Services shows incorrect cdp information

This checks out.  My theory is that Data Collection is not completing properly.  Run a new Campus Data Collection, then post the ani.log.

New Member

Re: LMS 3.2 Topology Services shows incorrect cdp information

I attach the ani.log file

Cisco Employee

Re: LMS 3.2 Topology Services shows incorrect cdp information

Data Collection seems to be completing.  Delete these two switches from the Campus map, then run a new Data Collection.  See if the proper CDP relationship shows up.

New Member

Re: LMS 3.2 Topology Services shows incorrect cdp information

Do I have to delete the devices from this menu ( Admin Data Collection Device Management Exclude Devices) or from topology services map?

thanks

Cisco Employee

Re: LMS 3.2 Topology Services shows incorrect cdp information

Delete them from Topology Services, then perform a new, full Data Collection.

New Member

Re: LMS 3.2 Topology Services shows incorrect cdp information

I deleted them from campus manager and that fix the problem thank you.

480
Views
0
Helpful
12
Replies
CreatePlease to create content