Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 3.2 Unable to add Device in CS DCR

Hi Joe,

In CS>Device management I am unable to add devices manually to DCR, the devices doesnt show up after add device wizard is finished.

However, devices are added in DCR using discovery, but hostname is not reflected as display name in DCR, although we have checked that option of using hostname as DCR display name in discovery settings. LMS is not integrated with ACS, however the devices are.

Please suggest how to proceed ?

Rgds

Gautam

Everyone's tags (7)
8 REPLIES
New Member

Re: LMS 3.2 Unable to add Device in CS DCR

Please find the attached debug log for System Module in CS. Also after discovery when i see summary, In reachable or discovered devices i could the hostname is correctly displayed but when i click on devices new added to DCR only IP is displayed in display name but not hostname.

Cisco Employee

Re: LMS 3.2 Unable to add Device in CS DCR

If LMS is installed on a multi-processor Windows server, your problem is most likely CSCtd07131.  A patch is available for TAC to fix this problem.

New Member

Re: LMS 3.2 Unable to add Device in CS DCR

I have tried the patch from TAC & it didnt fix this issue for me. Still after discovery device hostname not reflecting in DCR, they appear only by IP.

Any idea ?

Rgds

Cisco Employee

Re: LMS 3.2 Unable to add Device in CS DCR

The original problem you reported had to do with being able to add devices.  The fix from TAC would have no bearing as to whether or not devices added to DCR would be added by hostname.  For that, the IP addresses you see in your screenshot must be resolvable either in DCS or in the local hosts file.  You can use the NMSROOT/bin/resolver.pl to test this.  For example:

NMSROOT/bin/perl NMSROOT/bin/resolver.pl 172.21.12.163
New Member

Re: LMS 3.2 Unable to add Device in CS DCR

Thanks for reply Joe,

Yeah i was able to correctly display hostnames of devices in DCR, once after i've added hostnames entries in lmhosts file.

But I wonder if there could be a possible alternative to this scenario of resolving hostnames of devices without DNS.

Since its not always a case of adding devices in DNS records & suffix them with domain names. Moreover if

SNMP could read hostname MIB, it should add the hostnames automatically if DNS doesnt work.

Regards

Gautam Patel

Cisco Employee

Re: LMS 3.2 Unable to add Device in CS DCR

There is no hostname MIB.  However, I have an enhancement request open for Discovery to use sysDescr as the display name value without needing to do any name resolution on it.

New Member

Re: LMS 3.2 Unable to add Device in CS DCR

Hey Joe,

This enhancement request - have you have any feedback - will it be included ?

Cisco Employee

Re: LMS 3.2 Unable to add Device in CS DCR

Yes, it will be included in the next release of LMS tentatively due out this summer.

1546
Views
5
Helpful
8
Replies