Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 3.2 - Unable to start Topology Services from client ws

hello,

I have a problem starting Topology Service on client Work Station. Starting it from server is without any problem.

can anyone help, please ?

Hostname is DNS resolvable.

LMS 3.2 is instaled on windows server 2008 SP2 x64.

ERROR:

topology error.JPG

tanks in advanced.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: LMS 3.2 - Unable to start Topology Services from client ws

I still think something on the network is blocking this port.  To rule out a process problem, you can try telneting to the port on the server itself.  You should get an instant connection.  You can then try launching Topology Services from the server to see if that works.

12 REPLIES
Cisco Employee

Re: LMS 3.2 - Unable to start Topology Services from client ws

The hostname is not resolvable from the client.  On the server, run the hostname command from the DOS prompt.  Then, on the client, telnet to this hostname on port 42342.  Make sure you can establish a connection.  Then, open NMSROOT/lib/classpath/md.properties on the server.  Look for the property, PX_HOST.  Back on the client, telnet to that hostname value on the same port.  Again, make sure you can establish a connection.

If either hostname is not resolvable, fix that.  Either add the hostname to the client's DNS, or add the hostname to the C:\WINDOWS\system32\drivers\etc\hosts file on the client.

New Member

Re: LMS 3.2 - Unable to start Topology Services from client ws

Hi  Jo, first to say tanks for U'r time...

Hostname is same on dos prompt and in /md.properties file on the server.

Telnet can be established from client to server on port 42342, but I'm still geting same error message when I start topology services.


Please, what else can I do?

Cisco Employee

Re: LMS 3.2 - Unable to start Topology Services from client ws

One more thing to check is the full computer name under System Properties > Computer Name tab.  Make sure the Full computer name is resolvable on the client.  You should also confirm your client can connect to the hostname on port 43242.

New Member

Re: LMS 3.2 - Unable to start Topology Services from client ws

Hi Jo,

Thanks for U'r help.

My problem still exists. I can telnet to full hostname on port 42342,

but when I tried to connect on port 43242 i have error message: could not open connection to the host, on port 43242: Connect faile


how can I solve this problem?

Cisco Employee

Re: LMS 3.2 - Unable to start Topology Services from client ws

Post the output of the pdshow command from the server.  When you do the telnet from the client, does the error come back immediately, or does it take a few seconds?

New Member

Re: LMS 3.2 - Unable to start Topology Services from client ws

Error doesn't come back immediately, it tekas about 10 - 15 sec of trying to connect and then it shows error message.

I'm sending PDSHOW output from server attached.

Cisco Employee

Re: LMS 3.2 - Unable to start Topology Services from client ws

That points to a firewall problem.  The daemons are running so something on the network must be blocking the TCP traffic to 43242.  This port must be open between client and server.

New Member

Re: LMS 3.2 - Unable to start Topology Services from client ws

First to say Thanks for U'r help  mate.

I tried it with my firewal turned off  and AV software uninstaled , and I'm still unable to conect to port 43242.

i checked on server these ports are ok,

  TCP    0.0.0.0:42342          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:43242          0.0.0.0:0              LISTENING

do U have any other ideas, or U think it's just firewall or some other thing blocking that specific port???

Cisco Employee

Re: LMS 3.2 - Unable to start Topology Services from client ws

I still think something on the network is blocking this port.  To rule out a process problem, you can try telneting to the port on the server itself.  You should get an instant connection.  You can then try launching Topology Services from the server to see if that works.

New Member

Re: LMS 3.2 - Unable to start Topology Services from client ws

Hi Jo,

Tanks a lot  for all U'r help, It's working now,

I uninstaled AV software on server, added port 43242 as exception on client and server, and it's working now.U ware wright all the time mate!

cheers

New Member

Re: LMS 3.2 - Unable to start Topology Services from client ws

I can telnet to port 42342 and 43242 using the IP Address and Hostname, But unfortunately I still cannot open Topology Services from my laptop.

I already disable AV at my laptop and Ciscowork Server.

Looking forward for your advice.

Cisco Employee

Re: LMS 3.2 - Unable to start Topology Services from client ws

Please start a new thread for your issue.

1058
Views
5
Helpful
12
Replies