Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

LMS 4.0.1 Java installation 1330.A error

I'm installing a new platform LMS 4.0.1 under VMWare and Windows 2008 R2.

I installed via Windows 2008 R2 Patch without problem in LMS 4.0, then updated in LMS 4.0.1.

I'm facing several issues during this installation.

The first issue I have is the following:

When I launched topology services, java jre file jre-6u22-windows-i586-p_withjacorb.exe was downloaded and I saved it on disk.

I clicked on file to install it and get the following message during the installation:

Error 1330.A file that is required cannot be installed because the cabinet file C:\Users\lms\AppData\LocalLow\Sun\Java\jre1.6.0_22\Data1.cab has an invalid digital signature. This may indicate that the cabinet file is corrupt.

It tried to install certificate without success.

I have internet access to java.com but it seems publisher is not trusted.

Help will be appreciated.

Thanks

  • Network Management
1 ACCEPTED SOLUTION

Accepted Solutions

LMS 4.0.1 Java installation 1330.A error

Not seen your issue before but it is good to know.

I usually save the jre-6u22-windows-i586-p_withjacorb.exe file and later do a run-as admin.

Later I give full permissions on the directory  \program files\java\jre6\lib\endorsed\ for all Users of the pc.

It seems to need to write something there. maybe just once (should have but have not checked that yet)

Cheers,

Michel

3 REPLIES
New Member

LMS 4.0.1 Java installation 1330.A error

I opened a TAC SR and I got the following workaround explained in this link:

http://www.dabcc.com/article.aspx?id=17272

Workaround:

Java Development Kit includes a public version of the JRE that does not require certificate verification. THe goal is to extract JRE part of JDK kit.

- Download JDK 6u22 from Oracle site: http://www.oracle.com/technetwork/java/javase/downloads/index.html

- Begin to start JDK installation from exe file (jdk-6u22-windows-i586.exe) but STOP at the first Next button (do not install JDK kit).

- Locate JRE 6u22 .cab file (sj160220.cab) under c:\Documents and Settings\UserName\Application Data\Sun\Java\

jdk1.6.0_22 or c:\users\UserName\AppData\LocalLow\Sun\Java\jdk1.6.0_22 for Windows 7 or 2008.

- Double-click on .cab file, right-click and select extract to save files in a temp directory.

- Cancel JDK installation

- Double-click on jre.msi file to install JRE.


LMS 4.0.1 Java installation 1330.A error

Not seen your issue before but it is good to know.

I usually save the jre-6u22-windows-i586-p_withjacorb.exe file and later do a run-as admin.

Later I give full permissions on the directory  \program files\java\jre6\lib\endorsed\ for all Users of the pc.

It seems to need to write something there. maybe just once (should have but have not checked that yet)

Cheers,

Michel

New Member

LMS 4.0.1 Java installation 1330.A error

You're right Michel.

I forgot to mention that you need at the end to give write permissions to \program files\java\jre6\lib_endorsed directory to finalize the installation.

But even if you to try to start the installation with jre exec file as administrator, I got the same issue with 1330.1 error.

I think it's due to JRE data1.cab which is digitally signed and uses a Verisign code signing certificate that is not part of Microsoft root CA list.

JDK has a copy of JRE as part of the package that does not have this issue. The goal is to split out the JRE as a standalone installer.

Thanks

Patrice

1260
Views
5
Helpful
3
Replies