Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

LMS 4.0 Device Credential and Repository Showing as Empty

Dears,

I have a case for an LMS 4.0 running in a Live environement (With devices already discovered and organized into seperate groups), where the Device Credential and repository DCR is showing suddenly as empty and only i can see the groups listed, but without any devices in them (Through Inventory > Device Administration > Add/Import/Manage Devices).

After a restart of the whole LMS server a few weeks ago, the problem was fixed and the devices appeared again, but now the same issue re-appeared.

Any idea what might be the root cause and resolution for this?

Regards,

Everyone's tags (2)
5 REPLIES
Community Member

LMS 4.0 Device Credential and Repository Showing as Empty

We have the same problem, any ideas?

The problem results after the windows team patched our server..

But they have no idea was the problem could be.

regards

Community Member

LMS 4.0 Device Credential and Repository Showing as Empty

Download from Cisco the lms4.0.1-win-consolidated-cs-sept2011.zip patch, extract it to a folder in C:\ (Not in the Ciscoworks root directory).

From the command line CMD, go to the bin directory in Ciscoworks CSCOpx\bin and run the command:

perl C:\folder-extracted\CSCtr64005-0.pl

Once completed, restart the server and test.

Let me know about the outcome.

Regards,

Community Member

LMS 4.0 Device Credential and Repository Showing as Empty

Thanks for your infos, but the patch dont help.

the problem is still the same.

regards

Community Member

LMS 4.0 Device Credential and Repository Showing as Empty

Dear Marco,

Try the below 5 steps procedure, and let me know the end result.

STEP 1:

Check that the services are all running as expected. The services should have this status in a normal condition:

Start -> Control Panel -> Administrative Tools -> Services 

        CiscoWorks ANI database engine - Manual (if Campus Manager installed)

        CiscoWorks Daemon Manager - Automatic

        CiscoWorks RME NG database engine - Manual (if RME installed)

        CiscoWorks Tomcat Servlet Engine - Manual

        CiscoWorks VisiBroker Smart Agent - Manual

        CiscoWorks Web Server - Manual

        CWCS Cmf database engine - Manual

        CWCS rsh/rcp service - Automatic

        CWCS syslog service - Automatic

        CWCS tftp server – Automatic

        DFM dfmEpm database engine - Manual

        DFM dfmFh database engine - Manual

        DFM dfmInv database engine – Manual

STEP 2:

Change the CASUSER permissions in Windows and add it to the administrators group (In case it was not added).

STEP 3:

Force a checkpoint for RME and CMF databases (This returns the database pointer to good configuration point, without deleting any data), using the below procedure:

0) net stop crmdmgtd

1) In the command line go to NMSROOT\CSCOpx\databases\rmeng

2) From the command line, please run the command “dbsrv10 -f rmeng.db” for three  consecutive times

3) In the command line go to NMSROOT\CSCOpx\databases\cmf

4) Please run the command “dbsrv10 -f cmf.db” for three  consecutive times

5) net start crmdmgtd

STEP 4:

Do a reset for the CASUSER in the LMS application, using the below procedure:

Go to the location NMSROOT\CSCOpx\setup\support\  then double click on resetCasuser.exe (choose option number 1)

STEP 5:

Restart the server and check if the devices are appearing now.

Regards,

Community Member

LMS 4.0 Device Credential and Repository Showing as Empty

Hi

we have upgraded on LMS 4.1, now it works.

regards

Marco

852
Views
0
Helpful
5
Replies
CreatePlease to create content