Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 4.2.4: Missing entries in usertracking

Hi,

in the UT.log, I found a lot of the following entries:

EvalTask-vmpsadmin-04 VmpsAdminSMFGetBridgeTable: <switch-ip>skipping this vlan as time-out has expired for <vlan-name>com.cisco.nm.lib.snmp.lib.SnmpException: SnmpResponseAuthorizationError on <switch-ip> while performing SnmpWalk(*) at index = 0

at com.cisco.nm.lib.snmp.futureapi.SnmpFuture.value(SnmpFuture.java:195)

at com.cisco.nm.lib.snmp.futureapi.SnmpTableFuture.value(SnmpTableFuture.java:141)

at com.cisco.nm.ani.server.vmpsadmin.VmpsAdminSMFGetBridgeTable.fetchFdbTable(VmpsAdminSMFGetBridgeTable.java:202)

at com.cisco.nm.ani.server.vmpsadmin.VmpsAdminSMFGetBridgeTable.fetchBridgeTable(VmpsAdminSMFGetBridgeTable.java:163)

at com.cisco.nm.ani.server.vmpsadmin.VmpsAdminSMFGetBridgeTable.apply(VmpsAdminSMFGetBridgeTable.java:99)

at com.cisco.nm.ani.server.framework.EvalSMFApply.apply(EvalSMFApply.java:101)

at com.cisco.nm.ani.server.frontend.EvalPair.apply(EvalPair.java:108)

at com.cisco.nm.ani.server.frontend.EvalTask.run(EvalTask.java:51)

at java.lang.Thread.run(Thread.java:662)

SNMP connection tested from the Device Center is working fine, different models with different IOS Versions are effected, but other switches with same model and IOS are shown in the UT report.

Any idea how to investigate on that issue?

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: LMS 4.2.4: Missing entries in usertracking

UT needs the Bridge mib data, i.e, the Mac addr table/Cam table entry from device to show end hosts. With the error it is clear that LMS is not able to poll the bridge mib.

Bridge MIB is not as simple as directly polling device for data. It needs SNMP string indexing, which means it has to include @ sign after community to poll each vlan for mac addr's.

For example, the Catalyst switch includes one instance of the standard BRIDGE-MIB for each Virtual LAN in the switch. If the read-only community string is "public" and the read-write community string is "private", one could use "public@25" to read the BRIDGE-MIB for VLAN 25 and use "private@33" to read and write the BRIDGE-MIB for VLAN 33. If just "public" or "private" is used, the BRIDGE-MIB for VLAN 1 is accessed.

This is different when SNMP v3 is used. You have to configure snmp context than, as SNMP string indexing doesn't work on SNMP v3.

If you are using snmp v3, please check the following doc to see how contexts are created :

http://www.cisco.com/en/US/docs/switches/datacenter/sw/4_2/nx-os/system_management/configuration/guide/sm_9snmp.html#wp1070467

If using SNMP v1/v2c please manually poll the device by adding @ on community string and see it works.

-Thanks

Vinod

**Rating Encourages contributors, and its really free. **

-Thanks Vinod **Rating Encourages contributors, and its really free. **
3 REPLIES
Cisco Employee

Re: LMS 4.2.4: Missing entries in usertracking

UT needs the Bridge mib data, i.e, the Mac addr table/Cam table entry from device to show end hosts. With the error it is clear that LMS is not able to poll the bridge mib.

Bridge MIB is not as simple as directly polling device for data. It needs SNMP string indexing, which means it has to include @ sign after community to poll each vlan for mac addr's.

For example, the Catalyst switch includes one instance of the standard BRIDGE-MIB for each Virtual LAN in the switch. If the read-only community string is "public" and the read-write community string is "private", one could use "public@25" to read the BRIDGE-MIB for VLAN 25 and use "private@33" to read and write the BRIDGE-MIB for VLAN 33. If just "public" or "private" is used, the BRIDGE-MIB for VLAN 1 is accessed.

This is different when SNMP v3 is used. You have to configure snmp context than, as SNMP string indexing doesn't work on SNMP v3.

If you are using snmp v3, please check the following doc to see how contexts are created :

http://www.cisco.com/en/US/docs/switches/datacenter/sw/4_2/nx-os/system_management/configuration/guide/sm_9snmp.html#wp1070467

If using SNMP v1/v2c please manually poll the device by adding @ on community string and see it works.

-Thanks

Vinod

**Rating Encourages contributors, and its really free. **

-Thanks Vinod **Rating Encourages contributors, and its really free. **
New Member

LMS 4.2.4: Missing entries in usertracking

While switching to snmpv3, no contextes were configured

Cisco Employee

LMS 4.2.4: Missing entries in usertracking

Thanks for update. Glad it helped!

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **
224
Views
5
Helpful
3
Replies