Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

LMS 4.2.4 showing Link Trunk/NonTrunk Mismatch

Hello,

i have installed our LMS 4.2.4 and have discovered all our switches.

now i see under Discrepancies the Error "Link Trunk/NonTrunk Mismatch"

The reported switch is connected via vpc to 2 N7K´s and the link works fine, so i don´t understand this Error.

here is the Config of the Nexus Ports:

N7K1:

interface Ethernet3/26

  description vPC to switch1

  switchport

  switchport mode trunk

  switchport trunk allowed vlan 91-92,94,96,99,839

  spanning-tree port type normal

  udld disable

  channel-group 34 mode active

  no shutdown

interface port-channel34

  description vPC to switch 1

  switchport

  switchport mode trunk

  switchport trunk allowed vlan 91-92,94,96,99,839

  spanning-tree port type normal

  vpc 34

N7K2:

interface Ethernet3/26

  description vPC to switch1

  switchport

  switchport mode trunk

  switchport trunk allowed vlan 91-92,94,96,99,839

  spanning-tree port type normal

  udld disable

  channel-group 34 mode active

  no shutdown

interface port-channel34

  description vPC to switch1

  switchport

  switchport mode trunk

  switchport trunk allowed vlan 91-92,94,96,99,839

  spanning-tree port type normal

  vpc 34

And here the config of the switch (2960s):

interface GigabitEthernet1/0/49

description Trunk to n7k1

switchport trunk allowed vlan 91,92,94,96,99,839

switchport mode trunk

ip arp inspection trust

mls qos trust dscp

no vtp

channel-group 1 mode active

ip dhcp snooping trust

end

interface GigabitEthernet1/0/50

description Trunk to n7k2

switchport trunk allowed vlan 91,92,94,96,99,839

switchport mode trunk

ip arp inspection trust

mls qos trust dscp

no vtp

channel-group 1 mode active

ip dhcp snooping trust

end

interface Port-channel1

description Trunk to n7k

switchport trunk allowed vlan 91,92,94,96,99,839

switchport mode trunk

ip arp inspection trust

no vtp

ip dhcp snooping trust

and vtp is turned off (version 3, mode off).

do anyone has information regarding this error?

thank you!

kind regards,

Michael

Everyone's tags (4)
4 REPLIES
Cisco Employee

LMS 4.2.4 showing Link Trunk/NonTrunk Mismatch

Hi ,

I would suggest to Run the DATA Collection for that device Only from Topology MAP.

after the data collection is complted run a new user tracking Acquistion and check the status again.

Thanks-

Afroz

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

LMS 4.2.4 showing Link Trunk/NonTrunk Mismatch

Hi Afroz,

i tried this, but it didn´t help.

i also have connected a 3750x in the same way to the N7K´s, there is no issue.

the only difference of the configuration is, that i have to enter "switchport trunk encapsulation dot1q" for the Uplink Ports / Portchannel.

for the same switch (2960s) and the same ports i have also the discrepancy "Trunk  negotiation across VTP boundary"

anyhow, vtp is turned off:

VTP Version capable             : 1 to 3

VTP version running             : 3

VTP Domain Name                 : Access-XYZ

VTP Pruning Mode                : Disabled

VTP Traps Generation            : Disabled

Device ID                       : 1ce6.c788.e400

Feature VLAN:

--------------

VTP Operating Mode                : Off

Number of existing VLANs          : 11

Number of existing extended VLANs : 0

Maximum VLANs supported locally   : 255

Feature MST:

--------------

VTP Operating Mode                : Transparent

Feature UNKNOWN:

--------------

VTP Operating Mode                : Transparent

is there really a configuration issue, or that are only wrong messages from LMS?

kind regards,

Michael

Cisco Employee

LMS 4.2.4 showing Link Trunk/NonTrunk Mismatch

Hi Michael,

It looks like a wrong message from the LMS.

what happened when you click on FIX  ? did the discrepancies occured again after clicking  on fix.

Thanks-

Afroz

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

LMS 4.2.4 showing Link Trunk/NonTrunk Mismatch

Hi Afroz,

i clicked on FIX, but i don´t do the FIX of LMS, LMS want´s to set the Ports on the N7K´s and on the switch to "switchport mode dynamic desirable" - i think that is not a valid solution :-)

is it possible, that there is is simply a incompatibility of LMS between a N7K vPC and a 2960s?

there are also some faults reported regarding vtp - the only thing, what i want, is, that vtp is deactivated :-)

so i think, the vtp configuration is ok, so far.

do you have any recommends regarding this?

kind regards,

Michael

325
Views
0
Helpful
4
Replies