Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

LMS 4.2 cannot load mibs

Hello,

I have problems loading MIBs into Ciscoworks LMS 4.2

When I look at dependencies I see: RFC1212 but I cannot load this MIBs even it came with the LMS installation.

Error message:

Unable to load the MIB file. Error while compiling. Required dump file not available.

Regards

Frank

Everyone's tags (6)
13 REPLIES
New Member

LMS 4.2 cannot load mibs

Hi TAC engineers looking in  this threat. This functionality seams not to be working in this version. Do you have a hint, e.g. what upgrade could solve this or if this is MIB-loading just a not working fake feature where we should save our time with not looking deeper in.

Try to load the Power-Mib from APC USVs, that Mib-file is well working in ManageEngine.

Error message:

Unable to load the MIB file. Error while compiling. (Compared to RFC1212-MIB - without "Required dump file not available")

No changing logfile seen, to get useable causes, why MIB load failed

thx for hints in advance, Steffen

Cisco Employee

Re: LMS 4.2 cannot load mibs

Hi Steffen,

copy
.my file of your MIB under NMSROOT\hum\mibmanager\mibcompiler\mibs\

3.       Take the backup of mibcompiler.pl file under
NMSROOT\CSCOpx\hum\mibmanager\mibcompiler\ and replace attached
'mibcompiler.pl'.

4.       Take the backup of Compiler.pm file under
NMSROOT\hum\mibmanager\mibcompiler\lib\SNMP\MIB\ and replace attached
'Compiler.pm'.

5.       Now Goto Admin > Network > Monitor / Troubleshoot > Load MIB
and load  mib.

Thanks-

Afroz

[Do rate the useful post]

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

LMS 4.2 cannot load mibs

Hi Afroj,

Thx for your answers and your Files sent. But the problem still exists, because thats are probably the wrong files. The files you are sent are exactly the same as from LMS4.2.0, maybe we need this from LMS4.2.4 or from a special bugfix. I'm currently not allowed for upgrading to LMS4.2.4 in this customer environment.

Steffen

Cisco Employee

LMS 4.2 cannot load mibs

Hi Steffen,

send me the .MY file you are using..

Thanks-

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

Re: LMS 4.2 cannot load mibs

Hi Afroj,

attached the APC Powernet MIB

Steffen

Cisco Employee

Re: LMS 4.2 cannot load mibs

Hi Steffen,

try the same steps with the attached .MY file and see how it works

Thanks-

Afroz

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Cisco Employee

Re: LMS 4.2 cannot load mibs

Unzip the .my file before uploding

Thanks-

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

Re: LMS 4.2 cannot load mibs

Hi Afroj,

It tells to me the MIB already exists. After saying yes for upgrade the MIB it says, it successfuly upgraded the MIB.

But I want to import APC MIBs for the customer USVs to can do active monitoring using HUM. Unfortunaliy I cant type in the real wanted OIDs into a HUM monitoring template and have to use the graphical MIB browser nonsens to can type the template. So I'm dependend on a half working MIB compiler. Do you have any hints? Could I use the MIB-compiler from Commandline giving real hints about probably missing dependencies?

Steffen

Cisco Employee

LMS 4.2 cannot load mibs

Hi Steffen,

This means that there is no problem with LMS and compliers as you were sucessfuly able to upload the .my file.

I chekced the MIB that you were trying ,it was not a CISCO MIB , so I suspect this could be the issue.

If this is critical for you then I would suggest you to open a TAC case so that they can confirm this with Devlopment

Thanks-

Afroz

[Do rate the post]

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

LMS 4.2 cannot load mibs

Hi Afroj,

The MIB-file can be loaded from ManageEngine MIB-Browser and Tivoli Netcool successfuly.

This means, the MIB-file is OK.

Where is it written, that LMS does not should can load 3rd party MIBs?

Marketing says 3rt party monitoring is possible. How does it fit with a MIB compiler having an invisible 3rd party MIB barrier?

Steffen

New Member

hi.. i have the same problem

hi.. i have the same problem

 

the zip you attached only have the mibcompiler.pl .. where is the attached compiler.pm?

Thanks

Cisco Employee

here you go ..see the

here you go ..

see the attachment..

 

Hope it will help

I have changed the extension to .zip

 

Thanks-

Afroz

***Ratings Encourages Contributors ***

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

Thanks very much!I applied

Thanks very much!

I applied the procedure of replacing the files

Unfortunately, can't solve my problem

Here is my thread: https://supportforums.cisco.com/discussion/11598271/lms-v42-template-question (bottom) for details if you want to check it out

Thanks again!

Regards

909
Views
10
Helpful
13
Replies
CreatePlease to create content