Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 4.2 - SNMPv3 Auth and Priv Passwords Minimum Characters Length Limitation Issue

Hello,

I have an LMS 4.2.4 running on Solaris.

When I try to add a device with SNMPv3 auth and/or priv passwords that are less than 8 characters long, I get an error message.

Here is an example of the error message seen when the privacy password length is less than 8 characters (the auth password length is longer than 8 characters in this case):

Password and verify values for Privacy Password must be minimum of 8 characters length.

The error message appears as well if the authentication password length is less than 8 characters or if both auth and priv passwords length is less than 8 characters. Only the error message text is a bit different for authentication password.

The message appears either when trying to fill in the SNMPv3 credentials manually when adding a device or when creating a default credential set.

I found a known bug (CSCtr21972) which should have been already fixed in LMS 4.2 according to LMS 4.2 release notes.

I was running LMS 4.2 before the upgrade to 4.2.2 and 4.2.4 but I never tried adding a device with SNMPv3 credentials while running LMS 4.2, so I don't know if it had that limitation as well in 4.2.

I only tried this today after the upgrade to 4.2.2 and then again after the upgrade to 4.2.4.

In both versions I saw the error message.

Do you familiar with this limitation?

Do you know if there is any place where I can change it? I didn't find any SNMPv3 password policy like we have with the local users on LMS.

Attached is:

1.) Screenshot of the error message.

2.) Screenshot showing LMS version.

3.) Output of pdshow command.

4.) Output of uname -a command.

Thanks!

1039
Views
0
Helpful
0
Replies
CreatePlease login to create content