Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 4 DCR names reverting to IP address

I have an issue with LMS 4.1 where the DCR names of several devices repeatedly revert to the IP address.  I am trying to stage some devices for deployment.  The initial 5 devices were staged and are now off-line.  A subsequent set of 6 devices is on-line and accessible from LMS4.1.  The device names on the off-line devices are stable.  The device names of the on-line devices revert back to an IP address every day.  From device management, I go in and change the display name and the host name from the IP address to an alphabetic host name.  When I go back and look at it the next day, it has reverted to the IP address.  What is causing this?

Thanks,

-Jeff

Everyone's tags (4)
2 REPLIES

LMS 4 DCR names reverting to IP address

I assume that it is the DCR discovery; do you have added these devices to your DNS yet?; check this by using the following script:

NMSROOT\bin\perl NMSROOT\bin\resolver.pl

(with NMSROOT being the (short) installation path of LMS, eg. C:\Progra~1\CSCOpx)

if they are not in DNS, DCR will use the IP address if in the "Global settings" section of the discovery configuration "Update DCR Display" is opt-in.

Add the devices to your DNS (or the hosts file of the LMS server).

New Member

LMS 4 DCR names reverting to IP address

Thank you Martin for the reply and the thorough explanation.  I thought it might be a setting I could tweak.

I do not yet have the device names in DNS.  In the meantime, I tweaked the global discovery settings to prefer "Sysname" over DNS name (they are the same).

-Jeff

411
Views
0
Helpful
2
Replies