Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

LMS Campus Manager Topology Services

Hi all,

I have a problem trying to add 2 routers 2620XM to the Campus Manager Topology Services because they are not showing up in my topology map.

I have others 2620XM alredy in the topology map but for some reason these particular routers are not there. The only difference between this ones and the ones that are alredy in the map is that the 2 routers with problems have a

NM-1CE1U (It appears down in the CiscoView but it is up and running). Is there a compatibility problem with the 2620 routers?

regards

6 REPLIES
Cisco Employee

Re: LMS Campus Manager Topology Services

First check to make sure the devices are showing up in DCR, and that they have the correct SNMP credentials. Then, check your Campus Manager Data Collection filters to make sure those devices are not filtered out. Finally, run a new Campus Manager Data Collection, and check not only the Layer 2 View, but also the Unconnected Devices View to see if these devices are found.

If they are not, enable core and corex debugging under Campus Manager > Admin > Campus Data Collection > Debugging Options, then run another Campus Manager Data Collection. Then check the ani.log for the IP address and hostname of your missing routers, and see if there are any associated errors.

Community Member

Re: LMS Campus Manager Topology Services

Hi Joe,

The 2 devices appera in the layer 2 view, one as reachable and the other one as unreachable.

Is there a way to integrate the one that appears reachable to the topology map?

regards

Cisco Employee

Re: LMS Campus Manager Topology Services

I don't follow. You said the one that appears reachable is in the Layer 2 View. So it's already in the Topology Map. Specifically in which map is this 2600 not appearing?

Community Member

Re: LMS Campus Manager Topology Services

On the Topology Services I have 3 folders:

-Managed Domains

-Network Views

-Topology Views

If I open the Network Views folder there are 3 options:

-LAN Edge View

-Layer 2 View

-Unconnected Devices View

In the Layer 2 View I am able to see the two routers now as Reachable and if I do a rigth click and select "Display View" they appear in the topology map.

But If I Open the Topology Groups folder and select the Campus@CiscoWorks icon and select "All devices" the 2 routers don't appear and they are not diplayer if I select "Display View". Why are the routers appearing in the Layer 2 View but not in the Campus@CiscoWorks View?

regards

Community Member

Re: LMS Campus Manager Topology Services

Hi All,

I still have some problems with 2 routers not appearing in the campus topology map. I ran de core and corex debugs and look for possible errors for the routers I have problems with (192.168.12.242,192.168.12.54) and apparently the LMS is collecting information from this routers ( I am attaching the output) but they are not displayed in the campus topology map.

Is there a way to erase the map I have right now and start a new one?

Any suggestions are welcome.

Thanks!

Cisco Employee

Re: LMS Campus Manager Topology Services

It looks as if there is some stale data in the ANI database that is causing this device not to appear. The workaround for this is to reinitialize the ANI database, then perform a new Campus Data Collection. To reinitialize the ANI database, do the following:

NMSROOT/bin/perl NMSROOT/bin/dbRestoreOrig.pl dsn=ani dmprefix=ANI

201
Views
5
Helpful
6
Replies
CreatePlease to create content