Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : Not Found!!

Hi all,

I have a problem on Cisco LMS Server 2.6 which if i go into the netconfig job or any of the RME tasks, it comes up with this message:

Error occured while processing. Possible Cause: URN_NOT_FOUND : urn "JRM" : Not Found!!

When i checked the processes, it seems that the CTMJrmServer process cannot be started. The state of the process is always "Administrator has shut down this

server". Meanwhile all the other dependencies process like RMEDbMonitor, jrm, Tomcat Monitor, RMECSTMServer are running fine. Here I attached the

CTMJrmServer.log and jrm.log. Could anybody please give me a clue about this, need to solve very immediately. Thanks very much.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

I cannot give these steps out on the forum. If the you cannot open a TAC service request, the quickest way to recover would be to reinstall LMS now that the hostname has been changed within the OS.

13 REPLIES
Cisco Employee

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

The dates in the CTMJrmServer.log don't line up with the jrm.log. According to the jrm.log, jrm is functioning properly as of today. Please try running pdexec CTMJrmServer, and post the new CTMJrmServer.log. Also, please post the output of pdreg -l CTMJrmServer and the output of the set command.

New Member

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

Hi Joe,

Thanks alot for your reply! Here I attached the output of the syntax. Btw, I guess this is a hostname related problem?

Cisco Employee

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

Yes, you need to follow the hostname change procedure at http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_common_services_software/3.0/user/guide/diagnos.html#wp1078582 . Once you perform those steps, you need to modify the registry to change the hostname from zciscolms to zlms1 (under HKLM\SOFTWARE\Cisco).

New Member

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

Hi,

Can i know where to find the dbpassword or reset it for this command:

dbisqlc -c "uid=cmfDBA;pwd=dbpassword;eng=cmfEng;dbf=NMSROOT\databases\cmf\cmf.db" -q update PIDM_app_device_map SET app_hostname=`NewhostName' where app_hostname= `OldhostName'

because I think nobody know the password right now..

New Member

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

Maybe you could try c2kY2k for dbpassword or use dbpasswd.pl (located in NMSROOT\bin).

Cisco Employee

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

If you do not know the password, you will need to set it using the NMSROOT\bin\perl NMSROOT\bin\dbpasswd.pl command.

New Member

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

Thanks a lot for your posts, jclarke and rokp. The CTMJrmServer can started right now. And one question anymore, when i accessed the LMS homepage, all the links are still refer to the old hostname [ZCISCOLMS].

eg, the hyperlinks in the LMS home page:

Common Services [ZCISCOLMS]

Campus Manager [ZCISCOLMS]

is there anyway to change this to the new hostname? i have search *.xml in NMSROOT and sub folders and change whatever with the value "ZCISCOLMS" to "ZLMS1", but it doesn't work.

Thanks,

Jo

Cisco Employee

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

You missed a step in the hostname change procedure. See Step 6, and make sure you completed that correctly.

New Member

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

Oh okay, I had already redo all the procedures, and it seems now the hyperlinks are already point to the new hostname. Anyway, the hyperlinks for the Common Services menu are now disappeared from the LMS home page, so I had to type "http://zlms1:1741/cwhp/goHome.do" manually to access the Common Services homepage.

How can it be? Need help again for this.. Thanks very much for your great help.

Cisco Employee

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

I'm not sure how this happened, but it can be fixed. Unfortunately, the fix is not very straight forward. You will need to contact the TAC, and they can walk you through removing all of your CMIC registrations, then adding them all back from the command line.

New Member

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

Unfortunately I cannot have the TAC access at this moment and this problem have to be solved immediately. Anyway, can you give me any hints on how to fixing this?

Thanks very much for your help, always.

Cisco Employee

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

I cannot give these steps out on the forum. If the you cannot open a TAC service request, the quickest way to recover would be to reinstall LMS now that the hostname has been changed within the OS.

New Member

Re: LMS JRM Error, Possible Cause: URN_NOT_FOUND : urn "JRM" : N

Okay then, I will look for what is the best option for this case. Thanks very much jclarke!

942
Views
0
Helpful
13
Replies