Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

LMS upgraded now cannot connect to ANI server.

Oh boy I wish I hadn't touched it but there was so many things broken in the LMS 2.5.1 release that I upgraded everything to the following

Common services 3.0.4

Campus Manager 4.0.5

Ciscoview 6.1.4

Device Fault Manager 2.0.5

Integration Utility 1.6.0

Resource Manager Essentials 4.0.4

This is running on MS windows 2000 server

service pack 4.

When I try to run, for example topology services it hangs on connecting to ANI server and then says

Cannot connect to ANIserver 5.0.3

When I do a pdshow it isn't running, I do a pdexec ANIServer and it starts but I still cannot connect to it.

Also what is the Integration Utility, do I need to upgrade that ? I didn't.

?

Do I need to upgrade SWIM ? I didn't.

I also have a ticket open with the TAC but it's dragging on now and I'm.. my boss... :-) is looking for answers !

Thanks for any help guys

Darren

13 REPLIES
Cisco Employee

Re: LMS upgraded now cannot connect to ANI server.

What message are you getting when trying to access Campus Manager apps in the GUI? What is pdshow for ANIServer saying?

The integration utility is used when you have integrated with a 3rd party product like NNM, don't worry about it.

SWIM is part of RME and is upgraded when you upgrade RME.

New Member

Re: LMS upgraded now cannot connect to ANI server.

If I click on administration it will go to the next menu and a popup will come up saying

"Please wait.... ANI server is still initializing"

If I click on Topology services a popup will come up after a while saying

Cannot connect to ANI server: ANIServer5.0.3-ciscoworks

Probable Cause

Server not found...

Recommended Action

Verify that ANIServer5.0.3-ciscoworks is running and restart Campus Manager.

A pdshow ANIServer on the ciscoworks server

Process = ANIServer

State = running with busy flag set

Pid = 4080

RC = 0

Signo = 0

Start = 09/07/2006 03:43:44 PM

Stop = Not applicable

Core = Not applicable

Info = ANIServer started

Here's an interesting thing, why is it reporting that it's looking for ANIServer5.0.3

I upgraded campus manager to 4.0.5 ?

Thanks for your answer Davistan, I've noticed you helping a lot of people on this forum, sounds like you are one of the few who really know CW :-)

Cisco Employee

Re: LMS upgraded now cannot connect to ANI server.

From what you are seeing I would check the ANIServer.properties file

found in CSCOpx/campus/etc/cwsi

Have a look for these entries and correct them if need be....first stop the daemon manager if they needed to be edited:

In your file look for the entry AniName=ANIServer5.0.3. Make sure it is something like:

AniName=ANIServer5.0.3-hostname

Ex) My server name is sj-cwks so it would be

AniName=ANIServer5.0.3-sj-cwks

If the hostname portion is missing, go ahead and add it

---------------------------------------------

In your file check for DEVICESROOT= and make sure it has:

Solaris:

DEVICESROOT=/opt/CSCOpx/campus/lib/classpath

Windows:

DEVICESROOT=C:\\PROGRA~\\CSCOpx\\campus\\lib\\classpath

(keep in mind you may not have c:\\progra~, if not then add correct path to CSCOpx

---------------------------------------------

Check the entryu LogMsg.logfile=

It should have:

Solaris:

LogMsg.logfile=/var/adm/CSCOpx/log/ani.log

Windows:

LogMsg.logfile=c:\\CSCOpx\\log\\ani.log

---------

Restart daemon manager after applying changes

Let me know if this does the trick :)

New Member

Re: LMS upgraded now cannot connect to ANI server.

AniName=ANIServer5.0.3-ciscoworks

This was already there.

DEVICESROOT=D:\\PROGRA~1\\CSCOpx\\campus\\lib\\classpath

This was already there.

LogMsg.logfile=D:/PROGRA~1/CSCOpx/log\\ani.log

This is how it is, the path looks wrong to me?

I tried changing it to

LogMsg.logfile=D:\\PROGRA~1\\CSCOpx\\log\\ani.log

Cisco TAC told me to change the following but that hasn't worked either.

UserAuthentication=on to UserAuthentication=off

I also noticed that ANIServer does not come up with the box, I have to manually do a pdexec ANIServer to get it started.

Thanks for your help !

New Member

Re: LMS upgraded now cannot connect to ANI server.

Every time I click on topology services within campus manager I see this error appear in the ani.log file,

[Fri Sep 08 15:53:17 EDT 2006] ERROR: CORBAREGISTRY:Unable to connect to ManagerControl object. Reason: org.omg.CORBA.OBJECT_NOT_EXIST:

Could not locate the following Object:

repository id : IDL:manager/ManagerControl:1.0

object name : ManagerControl

host name : ciscoworks

minor code: 0 completed: No

1157745197453 September 8, 2006 3:53:17 PM ES_ciscoworks__1157744635406 ciscoworks Error EDSSY0012: Cannot connect to EDS.

Cisco Employee

Re: LMS upgraded now cannot connect to ANI server.

What is the state of the EDS process? What is the current COMPUTERNAME of this server? What is the output of:

NMSROOT\bin\perl NMSROOT\bin\resolver.pl ciscoworks

Where NMSROOT is the path into which CiscoWorks was installed.

Shutdown crmdmgtd (i.e. net stop crmdmgtd), and get the output of netstat -a -n.

New Member

Re: LMS upgraded now cannot connect to ANI server.

Hi,

How can I view the EDS process ?

I've added files with the output from the other

questions you've asked above.

Thanks !!!

Darren

Cisco Employee

Re: LMS upgraded now cannot connect to ANI server.

The EDS process can be viewed using pdshow EDS. There is also an EDS.log in NMSROOT\log that may prove useful.

One suspicious thing I noticed in your netstat output is that with CiscoWorks shutdown, there is still something listening on 1741/tcp. Please provide a list of all services and their startup parameters.

New Member

Re: LMS upgraded now cannot connect to ANI server.

Hi jclarke, thanks for your help with this.

EDS shows as "running normally" from pdshow.

Is there an easy way to get a list of all processes with startup params ? I know I can export a list from services but it doesn't

Do you mean only Ciscoworks procs or everything on the box ?

New Member

Re: LMS upgraded now cannot connect to ANI server.

Here is the output of pdshow EDS

The export list of services

The complete output of pdshow.

Cisco Employee

Re: LMS upgraded now cannot connect to ANI server.

You have messed up your service startup parameters. These MUST NEVER BE TOUCHED. You should never do anything relating to CiscoWorks in the Services control panel unless specifically requested by TAC. You must set the following services back to Manual, then reboot the server:

CiscoWorks ANI database engine

CiscoWorks Cmf database engine

CiscoWorks RME NG database engine

CiscoWorks Tomcat Servlet Engine

CiscoWorks VisiBroker Smart Agent

CiscoWorks Web Server

DFM dfmEpm database engine

DFM dfmFh database engine

DFM dfmInv database engine

New Member

Re: LMS upgraded now cannot connect to ANI server.

I will change these to the correct settings. I think I have even bigger problems with this server, it needs more disk and ram and I will need to completely re-install LMS.

Thanks for your help.

D

Cisco Employee

Re: LMS upgraded now cannot connect to ANI server.

Memory is critical with LMS. With the full bundle installed, you need at least 2 GB of RAM and 4 GB of swap just to start all the applications (this is with zero devices). If you are managing over 300 devices, you need 4 GB of RAM with 8 GB of swap (recommended; you can get away with less swap provided you have at least 4 GB).

Disk is also important. You definitely do not want to run out of space with CiscoWorks as that will lead to file and database corruption.

Good luck with the reinstallation.

384
Views
5
Helpful
13
Replies