Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

LMS3.0 upgrade - webserver access issue

Just upgraded from LMS2.6 to 3.0. Not able to login to application via browser. Have changed https port to no avail. Apache is running as are all LMS services as per Cisco doco. Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: LMS3.0 upgrade - webserver access issue

Okay. Based on what I've seen of your configuration, you should be able to restart dmgtd, and everything should now work:

net stop crmdmgtd

net start crmdmgtd

19 REPLIES
Cisco Employee

Re: LMS3.0 upgrade - webserver access issue

What error do you get trying to login?

New Member

Re: LMS3.0 upgrade - webserver access issue

The error is the standard "internet explorer cannot display the webpage" . The address box changes to http://lms_netmgr:1741/CSCOnm/servlet/login/login.jsp

Cisco Employee

Re: LMS3.0 upgrade - webserver access issue

Please post screenshots of your Services control panel, the output of pdreg -l Apache, the output of "set" from a DOS prompt, the outpu of pdshow, the NMSROOT\MDC\etc\regdaemon.xml file, and the NMSROOT\MDC\Apache\logs\error.log. If the data in these outputs is too sensitive to post, then please open a TAC service request with all of this information.

New Member

Re: LMS3.0 upgrade - webserver access issue

See attached pdreg, set, pdshow - others to follow

New Member

Re: LMS3.0 upgrade - webserver access issue

See attached regdaemon.xml, error.log

New Member

Re: LMS3.0 upgrade - webserver access issue

My services screenshot uploads are being blocked at present due to size and if I change to .zip for file type. Is there something specific you want me to check there?

Cisco Employee

Re: LMS3.0 upgrade - webserver access issue

Please zip them, and send them.

I also notice quite a few problems in what you've sent so far. The biggest being that DCRServer is in a waiting to initialize state. This could be due to a certificate problem. Based on your screenshots, I should be able to give you some steps to correct the problem, but I would now also like to see the NMSROOT\MDC\tomcat\logs\stdout.log.

New Member

Re: LMS3.0 upgrade - webserver access issue

See attached stdout.log

New Member

Re: LMS3.0 upgrade - webserver access issue

See attached Services screenshot page 1

New Member

Re: LMS3.0 upgrade - webserver access issue

See attached Services screenshot page 2

Cisco Employee

Re: LMS3.0 upgrade - webserver access issue

The problem points to the SSL port, 1050 according to your regdaemon.xml, not being properly bound. The Apache error.log mentions 1026, so I will need to see NMSROOT\MDC\Apache\conf\httpd.conf to see what is actually configured.

New Member

Re: LMS3.0 upgrade - webserver access issue

Thanks, I think a few attempted changes have muddied the picture here so I have attached fresh copies of some of the files.

I suspect that when using v2.6 we were using the standard https port however as we have IIS running we changed the port to 1026 during the upgrade. Apache would not run with this port hence the errors in the error.log file. We have since changed the port and Apache now runs. The latest files have the port as 1150. sorry about any confusion

New Member

Re: LMS3.0 upgrade - webserver access issue

Fresh copy of Apache error.log

Cisco Employee

Re: LMS3.0 upgrade - webserver access issue

Okay, this looks a little better. However, I would like to see the new pdreg output as well as the NMSROOT/lib/classpath/md.properties file, the new stdout.log, and the NMSROOT/lib/classpath/ssl.properties.

New Member

Re: LMS3.0 upgrade - webserver access issue

see attached as requested

Cisco Employee

Re: LMS3.0 upgrade - webserver access issue

The error in the stdout.log is the same: connection refused on the SSL port. This can mean only a few things. One, Apache cannot bind to tcp/1150 for some reason, or the client is detecting a different IP address or hostname for this server than is what is actually configured on it.

The best way to check for the former is to get the output of netstat -a -n -o -b while dmgtd is running. The best way to check for the latter is to start a sniffer trace on your client filtering on TCP traffic, then try to login.

Assuming you're still getting the same IE error, this will show us exactly what IE is trying to connect to.

New Member

Re: LMS3.0 upgrade - webserver access issue

Attached is the netstat output. Note that Apache is listening on port 1030 and 1741. this is in spite of me changing the port to 1150 using changeport. I had to manually configure the port to 1150 in the httpd.conf file which seemed odd.

When I type the url http://10.76.xxx.xxx:1741 and enter the url changes to http://10.76.152.252:1741/CSCOnm/servlet/login/login.jsp and the "Internet Explorer cannot display the webpage" error is displayed

Cisco Employee

Re: LMS3.0 upgrade - webserver access issue

Okay. Based on what I've seen of your configuration, you should be able to restart dmgtd, and everything should now work:

net stop crmdmgtd

net start crmdmgtd

New Member

Re: LMS3.0 upgrade - webserver access issue

It worked - fantastic. Thanks for your help

263
Views
0
Helpful
19
Replies
CreatePlease to create content