Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS3.1>RME>Config Management>NetConfig Jobs Problem

Hi,

I have created a jobs in NetConfig and i have the following Message :

Message: Deploy command partially failed (Primary Login  Succeeded / Primary Enable Succeeded)

The Task is Adhoc and i have added 3 instances.

Adhoc_1

file prompt quiet
rtest242(config)#

Adhoc_2

copy system:running-config ftp://user:pass@172.25.77.178/reseau/

Adhoc_3

no file prompt quiet
rtest242(config)#

1. The config is correctly copied on the server.

2. If i'm created 3 tasks, its run without erreur message.

Why i cant do this in 1 job.

Thx

6 REPLIES
Cisco Employee

Re: LMS3.1>RME>Config Management>NetConfig Jobs Problem

Enable ConfigJob debugging under RME > Admin > System Preferences > Application Loglevel Settings.  Then re-run the failing job and post the job directory from NMSROOT/files/rme/jobs/NetConfigJob.

New Member

Re: LMS3.1>RME>Config Management>NetConfig Jobs Problem

The job directory. I update the directory, the good one is 3079.

thanks

Cisco Employee

Re: LMS3.1>RME>Config Management>NetConfig Jobs Problem

Your template is out of order.  You've disabled "file prompt quiet" before the copy command runs.  Instead of trying to disable interactive prompts, just use Netconfig's interactive prompt handling feature to do what you want.  Change your template to be 100% enable mode with these contents:

copy system:running-config ftp://user:pass@172.25.77.178/reseau/172.25.77.178rtr-config

Where the trailing rtr-config is the value you'd enter at the second prompt.

New Member

Re: LMS3.1>RME>Config Management>NetConfig Jobs Problem

what 172.25.77.178 is doing ?

and rtr-config ?

thanks

Cisco Employee

Re: LMS3.1>RME>Config Management>NetConfig Jobs Problem

This denotes the prompt and response.  When Netconfig sees "" it means that what follows it is the response to one of the known interactive prompts.  The first question one should see from a copy to FTP operation is a prompt confirming the IP address of the FTP server.  The second prompt is the name of the file to copy.

New Member

Re: LMS3.1>RME>Config Management>NetConfig Jobs Problem

its good

Thanks

Michel

269
Views
0
Helpful
6
Replies
CreatePlease login to create content