Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

LMS4.2.5 User Tracking not discovering MAC addresses in tagged VLANs

hello all.

 

we are using Cisco Prime LMS4.2.5 and I have configured the user tracking Utility as per UT guide.

See screenshots attached.

I even have enabled "end host discovery on all trunks" in LMS.

In Addition I have activated the snmp MAC trap config on the switches accordingly.

 

We have configured all our endstation ports as "trunk" ports including a native VLAN.

See details bellow.

 

LMS UT is discovering and learning the MAC addresses being learned in the native (untagged) VLANs by the switches

BUT LMS does not get any MAC address from any tagged VLAN on the Switches.

 

Does anybode have any idea whats going wrong?

 

Thank you very much in advance,

Karl

 

interface GigabitEthernet2/0/15

description DATA & VOICE

switchport trunk native vlan 2201

switchport trunk allowed vlan 2201,2501

switchport mode trunk

switchport nonegotiate

switchport port-security maximum 50

no logging event link-status

snmp trap mac-notification change added

snmp trap mac-notification change removed

storm-control broadcast level 0.50 0.40

storm-control multicast level 0.50 0.40

storm-control action trap

no macro auto processing

no lldp transmit

no cdp enable

spanning-tree portfast trunk

spanning-tree bpduguard enable

end

3 REPLIES

When using SNMP v3 you must

When using SNMP v3 you must create a SNMP context for each VLAN.

Maybe this is your problem?

 

Cheers,

Michel

New Member

Hi Michel,thank you very much

Hi Michel,

thank you very much for your reply.

 

we are still on Snmpv2c for communication between LMS and the Cat3850 switches.

 

regards

Karl

 

If you see the mac address in

If you see the mac address in the show mac-address-table command, and LMS is unable to get them, I would open a ticket with TAC.

Since it can read from one VLAN, I fail to see why it can't read from another VLAN.

For the snmp trap mac-notification you must configure LMS to listen for these traps.

It will create a separate trap listener on a particular port.

You must also add a snmp-server host <IP of LMS> <port of mac-trap listener>

 

Cheers,

Michel

66
Views
0
Helpful
3
Replies