Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Migrating data from LMS 3.2 to LMS 4.2

I`m trying to migrate data from LMS 3.2 (windows) to LMS 4.2 (linux) I have run the backup job which contains many directories, I have created a .tar file to be able to ftp to LMS 4.2 but cannot get it to un-tar. Anyone been in this same scenario before?

Everyone's tags (2)
Cisco Employee

Share more details on what

Share more details on what error do you see. Do you still have the old backup files, without tar? What tar utility are you using?

I can suggest to use the tar utility available within LMS. Go to NMSROOT/bin directory and use:

1. To create tar : tar -cv <filename> <source_files>

2. To untar : tar -xvf <file_name>

Being the same utility it may be good. Anyways, this seems less of an LMS issue. If possible use an WINSCP and copy the entire directory without compressing.



-Thanks Vinod **Rating Encourages contributors, and its really free. **
Community Member

Vinod,Thanks for the reply. I


Thanks for the reply.

 I used 7zip to create the .tar file, then same untar command you suggested with results below. Also I tried using CoreFtp from my Windows server but cannot connect using admin id and password. Apparently that user is not setup as FTP user on LMS 4.2 server. I have decided to start rebuilding from scratch. Easy enough to export and import devices, Compliance Templates and etc.

[vacplp21/root-ade tmp]# tar -xvf 0.tar
tar: Skipping to next header
tar: Error exit delayed from previous errors


Cisco Employee

Agreed, fresh restart is the

Agreed, fresh restart is the easiest way to start all over. 

On the tar error, it seems some issues with the compression software compatibility.

You could have tried using the tar within LMS, even on windows, but for now, starting afresh should keep you out of such issues.



-Thanks Vinod **Rating Encourages contributors, and its really free. **
CreatePlease to create content