Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAM receives NDE traffic, but don't display nothing in "Monitor"

NAM receives NDE traffic, but don't display anything in "Monitor"

I've several routers exporting NetFlow v9 to a NAM 3.6(1). If I enable the “Listen Mode”, I see packets arrive to the NAM.

When I go to the “Monitor” tab and select “NETFLOW”, nothing is displayed.

What it's wrong?

Regards,

Waldemar Pera

12 REPLIES
Cisco Employee

Re: NAM receives NDE traffic, but don't display nothing in "Moni

Netflow 9 is not yet supported by the NAM. Support for this version is planned for NAM 4.0. Currently, you must be exporting 1, 5, 6, 7, and 8 (with support for v8 aggregation caches as well).

New Member

Re: NAM receives NDE traffic, but don't display nothing in "Moni

Thanks Joe,

I think that but, if you see the NAM 3.6 DS (http://www.cisco.com/en/US/prod/collateral/modules/ps2706/ps5025/product_data_sheet0900aecd804bab11.html):

Supported topologies and data sources

LAN: Switch Port Analyzer (SPAN), Remote SPAN (RSPAN), VLAN ACL (VACL)-based captures, NetFlow (versions 1, 5, 6, 7, 8, and 9)

WAN: NetFlow (versions 1, 5, 6, 7, 8, and 9) from local and remote devices, VACL-based captures for FlexWAN/Optical Service Module (OSM) interfaces (Cisco IOS Software only)

Does it is a documentation error?

Thanks and regards.

Cisco Employee

Re: NAM receives NDE traffic, but don't display nothing in "Moni

There seems to be some conflicting information. The NAM's help does not list version 9 as being supported, and I have seen an internal note that it works, but AS information is not shown.

Assuming you are seeing the packets, add a Netflow source, then go to Setup > Monitor, select your Netflow source, and enable the features you wish to monitor.

New Member

Re: NAM receives NDE traffic, but don't display nothing in "Moni

Joe, I've tried manually and "Listen Mode" to add the NDE devices.

Also, I've enabled the "Setup > Monitor" to NetFlow.

The results are the same: nothing appears in "Monitor" when I select "NETFLOW".

??

New Member

Re: NAM receives NDE traffic, but don't display nothing in "Moni

Note: I will to upgrade NAM OS 3.6(1a) and update with Patch 3.0.

Cisco Employee

Re: NAM receives NDE traffic, but don't display nothing in "Moni

One other thing you can try is to change the NDE version on one of the devices. I am using version 5 in my lab, and it works fine. This would be consistent with the NAM 3.6 online help.

New Member

Re: NAM receives NDE traffic, but don't display nothing in "Moni

Two devices are NetFlow v9 (the NAM-2 show the V9 Templates) and one is NetFlow v5.

NAM OS is 3.6(1a) Patch 3.0 + Crypto Path.

When in "Setup > Data Sources > NetFlow > Devices" I select a device and press "Test", the window shows "Netflow on device: Configuration unknown"

Cisco Employee

Re: NAM receives NDE traffic, but don't display nothing in "Moni

Make sure the SNMP read community string you have specified for this device is valid, and that the NAM has the ability to query this device with SNMP.

New Member

Re: NAM receives NDE traffic, but don't display nothing in "Moni

NetFlow v5 and v9 working.

Situation: If I enable the individual sources to "Monitor" (each router), I see the NetFlow individually but it isn't work if select NETFLOW under "Monitor" tab.

This doesn't happend with SPAN/RSPAN/VACL source. Always, I see the information like SPAN or by each DATAPORT.

Maybe a bug?

Cisco Employee

Re: NAM receives NDE traffic, but don't display nothing in "Moni

The NETFLOW component is NetFlow from the local switch. It is not an aggregation of all NDE sources. To see data for each NDE source, you would have to select each source in turn.

New Member

Re: NAM receives NDE traffic, but don't display nothing in "Moni

Thanks. It was a wrong concept from me.

Now, do you now a good source to configure NetFlow into Cat6500 (Sup720)?

Thanks to much.

Cisco Employee

Re: NAM receives NDE traffic, but don't display nothing in "Moni

366
Views
0
Helpful
12
Replies