Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Netconfig corrupting passwords

I used Netconfig to change passwords on approximately 1000 switches. I applied this command on several different switch models and IOS versions:

username xxx privilege 15 password 7 *******

After the job got executed, the passwords got corrupted on the 4506s specifically, and I could not log on to them with either the old or the new password. They had a corrupted hash, different from the old and the new one, although the job execution was successful! Most of the rest of the devices worked fine.

I used ciscoworks LMS2.5.1, RME 4.0.4

Can anyone help me to shed some light on this? I am reluctant now on using ciscoworks to change passwords again. what do you propose I should do next time?



Cisco Employee

Re: Netconfig corrupting passwords

I know of a problem in Config Editor in RME 4.0.4 where lines would be duplicated and dropped, but I have not seen a password get corrupted in Netconfig. To debug these problems, I would suggest enabling ConfigJob debugging under RME > Admin > System Preferences > Loglevel Settings, re-run the job, then check the job log under NMSROOT\files\rme\jobs\NetConfigJob\ to see what it's deploying to the switch.

Additionally, provided you're not using an encrypted deployment protocol, you can get a sniffer trace to sanity check what RME is doing.

RME should not be encrypting the password itself, but should send it down to the switch however you specified it in Netconfig.

Be careful that you are not deploying a clear-text password, but saying it is encrypted. That is, when you specify a level 7 password explicitly, it is expected that this password is already encrypted using Cisco's two-way encryption algorithm.

New Member

Re: Netconfig corrupting passwords

Hi Nathalie

Regarding the problem you are reporting, I had a similar case some month ago. For further password changes I solved the problem in the way, that I activated the password encryption service on all devices and sent unencrypted passwords with CiscoWorks. Since this change in the way to rollout new passwords, I never recognized any problems again.



Re: Netconfig corrupting passwords

One thousand switches seems like quite a lot of switches to be maintaining local user accounts on.

Have you ever considered installed a TACACS+ server and configuring the switches to authenticate off it instead? This way password changes are as simple as changing the password in one place on the TACACS+ server.

CreatePlease login to create content