Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

netconfig devicefile invalid argument

Hi,

I use LMS 3.1

I run exactly the same command but I get th following message:

cwcli netconfig createjob -u admin -p password -devicefile /opt/CSCOpx/bin/test.list -commandfile command.file -policyfile policy.in -description "cwcli netconfig job" -mode config

<cwcli> FATAL - NETCLI014:Netconfig createjob command failed

<cwcli> FATAL - Invalid argument: officeuk

my test.list file content is:

cat test.list

officeuk

The weird thing is that if I run the same command but without having a file but device (-device officeuk), it works!

I can't see any reason why this is not working, can u?

what is the correct argument did i miss something? I read the netconfig's manual and it is said to enter devices name contained in RME database.

regards

alex

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: netconfig devicefile invalid argument

This is a bug in the documentation. The device file must be an extension of the regular CLI. So, the syntax is:

-device device1[,device2[,device3[,...]]]

In your case, this will work:

% cat test.list

-device officeuk

3 REPLIES
Cisco Employee

Re: netconfig devicefile invalid argument

This is a bug in the documentation. The device file must be an extension of the regular CLI. So, the syntax is:

-device device1[,device2[,device3[,...]]]

In your case, this will work:

% cat test.list

-device officeuk

New Member

Re: netconfig devicefile invalid argument

it worked! thank you very much

i guess if i have more then 1 device the file will contain something like that:

- device device1,device2,device3,etc...

regards

alex

New Member

Re: netconfig devicefile invalid argument

thank yu very much it is working by now

142
Views
0
Helpful
3
Replies
CreatePlease to create content