Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started.

New Member

Netconfig problem

Using LMS 2.5.1 on Windows 2003. I can no longer successfully use Netconfig to deploy device changes. When I run Netconfig jobs the jobs end immediately with a status of successful. However the job doesn't actually do anything. I don't even get an email about the job running. When I look at the job report it only has a Workorder section and no Device Detail section. This seems to have broke after installing the December 2005 update. I have a TAC case open. They first had me re-index the RME and CMF databases but this changed nothing. They point out the following message in the job log as indicating a problem connecting to the DB:

"FATAL,[main],com.cisco.nm.rmeng.config.ccjs.executor.CfgJobExecutor,main,50,Exception while executing the joborg.omg.CORBA.BAD_PARAM: minor code: 0 completed: No

oborg.omg.CORBA.BAD_PARAM"

They now want me to re-init all my databases. I don't really want to do this as this seems a bit drastic. Any ideas?

  • Network Management
6 REPLIES
Silver

Re: Netconfig problem

Think, you might have go with reiniting the database, you may refer to the RME troubleshooting in the following link for some tips :

http://www.cisco.com/en/US/products/sw/cscowork/ps2073/prod_troubleshooting_guide09186a008036dff2.html

New Member

Re: Netconfig problem

I'm experiencing the same problem. Worked fine before I applied CM4.0.4 though.

Re: Netconfig problem

I think I had the same problem for some jobs but configuring it a second or third time exactly the same way the job was created successfully. Try to configure it again (and just let the old one in the DB) If the job will be ok one time I don´t think that reinit will solve the problem as it seems to be a problem with the process of creating the job and not a problem with the DB.

(In my case the DB only had 102 devices...)

MArtin

New Member

Re: Netconfig problem

I have tried creating the job many times and I allways have the same problem - The job ends right away with a status of successful but the job doesn't actually do anything.

Re: Netconfig problem

Ok, if TAC says it seems to be a problem while connecting to the DB, try to reset the DB password using the cli tool in /CSCOpx/bin/dbpasswd.pl

on windows:

1) Stop LMS form cli

net stop crmdmgtd

2) change the DB passwds(or just use the old one) for RME

cd C:\Program Files\CSCOpx\bin

perl dbpasswd.pl dsn=rmeng npwd=

for CMF

per dbpasswd.pl dsn=cmf npwd=

Restart the daemons

net start crmdmgtd

clear all the caches (IE and Java)

and try it again

New Member

Re: Netconfig problem

I have already tried resetting the DB passwords and clearing the java cache. This didn't fix things.

139
Views
0
Helpful
6
Replies