Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Network Analysis module problem (TOP URGENT)

while generating reports for any particular slots not able to change the port numbers as well as when trying to monitor different ports not able to choose other ports.

Even after rebooting ad re-inserting the ports are not changing to analyze/monitor the traffic.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Network Analysis module problem (TOP URGENT)

It looks like a bug had already been filed for this (CSCso56732), and it is fixed in NAM code 3.6(1b).

10 REPLIES
Cisco Employee

Re: Network Analysis module problem (TOP URGENT)

Are you saying that these pull-downs don't contain other values? What version of NAM code are you running?

New Member

Re: Network Analysis module problem (TOP URGENT)

*Please have a look at the image i have attached in my last post.

Whenever we are trying to add a Report, we are unable to add the ports to the nam for monitoring.

for eg: if we want to monitor the switchport 4/1 in the 4th module, we go to the reports > create > switchports> and are able to select the module, but on the same go Port (sub-module) doesn't change , so we are unable to add it to the reports.

Cisco Network Analysis Module (WS-SVC-NAM-2) 3.6(1a)

Maintenance image version: 2.1(2)

BIOS Version: 4.0-Rel 6.0.9

NAM Daughter Card Micro code version: 1.34.1.28 (NAM

Please advise me with a solution.

(F.Y.I. i have pulled out the NAM from the switch and inserted the same NAM module to our spare switch, there its working fine, and we are able to add reports as well)

Cisco Employee

Re: Network Analysis module problem (TOP URGENT)

I've looked at the screenshot, but it doesn't answer my question. Is it that the pull-downs only have information for module 3? That is, do you not see module 4 in the module list? I would like to see the show techs from the switch and NAM as well.

New Member

Re: Network Analysis module problem (TOP URGENT)

Hi,

I am able to view all the "switch modules" by scrolling from 1 to 9 of all the modules, but the PORT doesn't changes anymore.

I am attaching herewith show techs from the switch and the NAM.

Please suggest me a solution at the earliest.

Cisco Employee

Re: Network Analysis module problem (TOP URGENT)

Okay, I think I understand. I think this has to do with the port names messing up Javascript. I'm betting the problem port is Gi8/14. This port contains a '\'' character. Can you try changing this port's description, and see if the problem goes away?

New Member

Re: Network Analysis module problem (TOP URGENT)

Hats off !!

Problem is solved.

I would be really obliged if you could tell me how and where you identified the issue from all of my logs..... This would help me in answering/justifying myself in front of my management.

thanks a lot....

Cisco Employee

Re: Network Analysis module problem (TOP URGENT)

It was more of a hunch than anything I saw in the logs.

New Member

Re: Network Analysis module problem (TOP URGENT)

then how did you get to know its interface gi8/14, which is creating the issue......

could you pls tell me which part of the logs you found it...

and how could i resolve such issues in future.....

Cisco Employee

Re: Network Analysis module problem (TOP URGENT)

This came from an understanding of the NAM code, Javascript, and looking at your show tech. There was nothing in the logs per se that indicated a problem.

In the future, just make sure not to include single quotes in port names.

Cisco Employee

Re: Network Analysis module problem (TOP URGENT)

It looks like a bug had already been filed for this (CSCso56732), and it is fixed in NAM code 3.6(1b).

238
Views
0
Helpful
10
Replies
CreatePlease to create content