Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Nexus syslog format problem

Hello,

I work with cisco nexus 1000v  (os image nexus-1000v-kickstart-mz.4.2.1.SV1.5.1.bin)

I have problems with syslog messages I receive on syslog server.

All messages I receive on syslog server don't have host name, which make it difficult to identify

the origin of the message.

It looks like that (on syslog server):

<190>: 2012 Jun  6 07:52:20 UTC: %AAA-6-AAA_ACCOUNTING_MESSAGE: update:192.168.5.88@pts/5:admin:configure terminal ; logging level aaa 7 (SUCCESS)

<190>: 2012 Jun  6 07:52:25 UTC: %AAA-6-AAA_ACCOUNTING_MESSAGE: update:192.168.5.88@pts/5:admin:configure terminal ; ip access-list qqq (SUCCESS)

<190>: 2012 Jun  6 07:52:30 UTC: %AAA-6-AAA_ACCOUNTING_MESSAGE: update:192.168.5.88@pts/5:admin:configure terminal ; ip access-list qqq ; 22 permit ip any any (SUCCESS)

But on the device it looks like that:

2012 Jun  6 07:52:20 roei_nexus %AAA-6-AAA_ACCOUNTING_MESSAGE: update:192.168.5.88@pts/5:admin:configure terminal ; logging level aaa 7 (SUCCESS)

2012 Jun  6 07:52:25 roei_nexus %AAA-6-AAA_ACCOUNTING_MESSAGE: update:192.168.5.88@pts/5:admin:configure terminal ; ip access-list qqq (SUCCESS)

2012 Jun  6 07:52:30 roei_nexus %AAA-6-AAA_ACCOUNTING_MESSAGE: update:192.168.5.88@pts/5:admin:configure terminal ; ip access-list qqq ; 22 permit ip any any (SUCCESS)

Maybe somebody encountered such problem and know how to change message format that it will contain hostname/ip on the remote server.

Thank you

Everyone's tags (3)
2 REPLIES
Blue

Nexus syslog format problem

Do you have "hostname [hostname]" configured?

What's your current "show run" look like?

Community Member

Nexus syslog format problem

Yes definitely I have hostname configured,

here is my config:

!Command: show running-config

!Time: Thu Jun  7 07:48:15 2012

version 4.2(1)SV1(5.1)

feature telnet

logging level aaa 7

username admin password 5 $1$NkkczGV.$cvskA7PlYvB2S1/9pYLKt1  role network-admin

banner motd #Nexus 1000v Switch#

ip domain-lookup

ipv6 host tuf 2222::1111

ip host evgeny_desck 192.168.5.88

ip host evgeny_desck2 192.168.5.81

hostname roei_nexus

system default switchport

logging event link-status default

ip access-list Vlan2014_ingress

  statistics per-entry

  1 permit ip any any

  2 permit icmp any any

  3 permit tcp any any

  4 permit udp any any

ip access-list ddd

  10 permit ip any any

  20 permit ip any any

  30 permit ip any any

  50 permit ip any any

  100 permit ip any any

  110 permit ip any any

  120 permit ip any any

  130 permit ip any any

  160 permit ip any any

ip access-list evgeny_acl

  10 permit icmp any any

  20 permit ip any any

  30 permit tcp any any

  40 permit udp any any

  50 deny ip 2.2.2.2/32 3.3.3.3/32

  51 deny ip 2.2.2.2/32 3.3.3.3/32

ip access-list lab

  statistics per-entry

  10 permit ip 10.0.0.0/8 any

  20 deny ip 192.168.1.0/24 any

ip access-list shay

  20 permit tcp any any eq www

  30 permit tcp 5.5.5.0/24 any eq exec

  40 permit udp 1.1.1.1/32 range isakmp rip 2.2.2.0/25 eq snmp dscp cs3

  50 permit udp 1.1.1.1/32 2.2.2.2/32 eq 66

  60 permit tcp any neq nntp any neq nntp

  70 permit tcp any neq nntp any neq nntp syn

  80 permit tcp any neq nntp any neq nntp ack

  90 permit tcp any neq nntp any neq nntp rst

  100 permit tcp any neq nntp any neq nntp fin

  110 permit tcp any neq nntp any neq nntp dscp cs1

  120 permit tcp any neq nntp any neq nntp urg

  130 permit tcp any neq nntp any neq nntp psh

  140 permit tcp any neq nntp any neq nntp established

  150 permit tcp any any eq 8080

  160 permit tcp any 88.88.88.0/26 eq 8080

ip access-list tuf

  10 permit tcp any any eq www

  20 permit ip any any

snmp-server user admin network-admin auth md5 0xb010a509f59f94aeb07c3d08d8d035f9 priv 0xb010a509f59f94aeb07c3d08d8d035f9 localizedkey

snmp-server community snmp4u group network-operator

vrf context management

  ip route 0.0.0.0/0 10.17.1.1

  ip route 0.0.0.0/0 192.169.1.2 1

vlan 1

vlan 1

port-channel load-balance ethernet source-mac

port-profile default max-ports 32

vdc roei_nexus id 1

  limit-resource vlan minimum 16 maximum 2049

  limit-resource monitor-session minimum 0 maximum 2

  limit-resource vrf minimum 16 maximum 8192

  limit-resource port-channel minimum 0 maximum 768

  limit-resource u4route-mem minimum 1 maximum 1

  limit-resource u6route-mem minimum 1 maximum 1

  limit-resource m4route-mem minimum 58 maximum 58

  limit-resource m6route-mem minimum 8 maximum 8

interface mgmt0

  ip access-group evgeny_acl in

  ip access-group evgeny_acl out

  ip address 192.168.21.10/16

interface loopback1

interface loopback17

  no ip redirects

  ip address 20.20.20.22/24

  ip address 20.20.22.22/24 secondary

  ip address 20.20.22.23/24 secondary

interface loopback23

  ip address 88.88.88.88/24

  ipv6 address 2620::1b05:1401:0000:0000:0000:0005/128

interface control0

  ip address 192.168.21.11/16

line console

boot kickstart bootflash:/nexus-1000v-kickstart-mz.4.2.1.SV1.5.1.bin sup-1

boot system bootflash:/nexus-1000v-mz.4.2.1.SV1.5.1.bin sup-1

boot kickstart bootflash:/nexus-1000v-kickstart-mz.4.2.1.SV1.5.1.bin sup-2

boot system bootflash:/nexus-1000v-mz.4.2.1.SV1.5.1.bin sup-2

ip route 0.0.0.0/0 192.168.1.2

ip route 45.45.45.0/24 10.17.1.99

ip route 50.50.50.0/30 10.100.0.77

ipv6 route 0::/0 fd80::1111

svs-domain

  domain id 2

  control vlan 1

  packet vlan 1

  svs mode L3 interface mgmt0

vsn type vsg global

  tcp state-checks

vnm-policy-agent

  registration-ip 0.0.0.0

  shared-secret **********

  log-level info

logging logfile evgeny.log 7

logging server 192.168.21.2 7

logging module 7

logging timestamp milliseconds

944
Views
0
Helpful
2
Replies
CreatePlease to create content