Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

No getting DHCP address

Hello,

I have on Cisco Soho 97 adsl router. I have set a dhcp server like this:

ip dhcp pool Test

network X.X.X.X Y.Y.Y.Y

default-router Z.Z.Z.Z

dns-server A.A.A.A B.B.B.B

domain-name test.com

lease 7

With this settings my PC doesn't get any address.

When I look dhcp statistics on the router there are nothing in DHCP_Discover like the are not communicating.

However, if I put static address in my PC I can ping the router.

I would be grateful for anay help.

P-S: DHCP service is running and I have IOS on 12.4 version.

7 REPLIES
Community Member

Re: No getting DHCP address

"service dhcp"?

from:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120t/120t1/easyip2.htm#25419

By default, the Cisco IOS DHCP Server feature is enabled on your router. If the feature is disabled, use the following command in global configuration mode to reenable the Cisco IOS DHCP Server feature on your router:

Community Member

Re: No getting DHCP address

As I wrote in my first message, the service DHCP is running.

Is there a known bug with DHCP and IOS 12.4 ?

Hall of Fame Super Gold

Re: No getting DHCP address

Julien

While we can not dismiss the possibility of an IOS bug I am not aware of a general bug with DHCP in 12.4. I suspect that it is more likely to be an issue with your configuration. Your effort to disguise information gives us nothing useful to work with in diagnosing what the problem might be. If you can post some details of the configuration of the interface and the details of the DHCP configuration we might be able to identify the problem. If you feel the need to protect information then I suggest that you change the value of the first octet being sure to maintain the same class A, class B, or class C address space.

HTH

Rick

Community Member

Re: No getting DHCP address

Thanks Rick for your help.

This my config, thanks by advance

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname MyHostname

!

boot-start-marker

boot system flash soho97-k9oy1-mz.124-10a.bin

boot-end-marker

!

enable secret 5 MySecret

enable password 7 MyPassword

!

no aaa new-model

no ip routing

no ip dhcp use vrf connected

ip dhcp excluded-address 172.18.15.200 172.18.15.254

!

ip dhcp pool Client

network 172.18.15.0 255.255.255.0

default-router 172.18.15.254

dns-server 172.18.4.11 172.18.4.12

domain-name Mydomain.com

lease 42

!

!

no ip cef

!

!

!

!

!

!

!

!

interface Ethernet0

ip address 10.2.15.254 255.255.255.0 secondary

ip address 172.18.15.253 255.255.255.0

no ip route-cache

no ip mroute-cache

bridge-group 1

hold-queue 100 out

!

interface ATM0

no ip address

no ip route-cache

no ip mroute-cache

no shutdown

no atm ilmi-keepalive

dsl operating-mode auto

bridge-group 1

pvc 8/35

pppoe-client dial-pool-number 1

!

!

no ip http server

no ip http secure-server

!

!

dialer-list 1 protocol ip permit

!

control-plane

!

bridge 1 protocol dec

!

line con 0

no modem enable

stopbits 1

line aux 0

stopbits 1

line vty 0 4

password 7 MyVirtualPAssword

login

!

scheduler max-task-time 5000

end

Hall of Fame Super Gold

Re: No getting DHCP address

Julien

Thanks for posting the additional information. I have looked at the config that you posted and have these comments:

- the DHCP config looks reasonable and I do not see any particular problem with it.

- I am not sure why the DHCP specifies the default-router 172.18.15.254. The interface address is 172.18.15.253 so is the default router something that is connected?

- I am surprised that you have turned off IP routing and have turned on bridging. I suspect that turning off IP routing may be the cause of the failure of the DHCP. Is it possible to turn on IP routing and see if the DHCP works then?

HTH

Rick

Community Member

Re: No getting DHCP address

Thanks Rick,

In fact the default router is not my cisco router but a firewall. And the adsl connection is made by the firewall with the bridge interface of the router.

This config works fine on another site, that's the reason why I don't understand why my DHCP doesn't work.

If I look the statistics 0 is present everywhere.

I will try enable routing to see if it is the solution. I will try tomorrow.

Community Member

Re: No getting DHCP address

Hi Ricks,

After testing, it seems that it's that the problem come with the bridge configuration. DHCP and bridge configuration are not possible ?

252
Views
0
Helpful
7
Replies
CreatePlease to create content