Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ntp: router unsyncs from parent one even when parent synched; both masters

router unsyncs from parent one even when parent router still synched; both are ntp masters

a router configured as ntp master ... can sometimes unsync ? ... or is it a bug ?

eg:

EDGE ROUTER # 1 (e.e.e.1):

ntp master 3

ntp update-calendar

ntp server 146.164.48.5

ntp server 192.5.41.209

ntp server 200.54.149.19

ntp access-group serve-only 1 ... allowing 146.164.48.5, 192.5.41.209, 200.54.149.19 only

ntp access-group peer 2 ... allowing i.i.i.1 only

address ref clock st when poll reach delay offset disp

~127.127.7.1 127.127.7.1 2 - 64 0 0.0 0.00 16000.

*~200.54.149.19 .GPS. 1 121 256 363 63.9 -29.29 2042.3 <----- synched with valid one

+~146.164.48.5 .GPS. 1 192 256 177 307.5 -43.31 160.0

+~192.5.41.209 .USNO. 1 183 256 177 206.7 -30.60 42.7

* master (synced), # master (unsynced), + selected, - candidate, ~ configured

EDGE ROUTER # 2 (e.e.e.2):

same as above

INTRANET ROUTER (i.i.i.1) synched to edge routers:

ntp master 4

ntp update-calendar

ntp server e.e.e.1 source <interface-connected-to-edge-1>

ntp server e.e.e.2 source <interface-connected-to-edge-2>

address ref clock st when poll reach delay offset disp

*~127.127.7.1 127.127.7.1 3 20 64 7 0.0 0.00 3875.0 <----- synched to master, why ?

~e.e.e.1 200.54.149.19 2 8 64 7 7.3 -22.24 3884.1

~e.e.e.2 0.0.0.0 16 - 64 0 0.0 0.00 16000. <----- router powered off, showed as insane, OK

* master (synced), # master (unsynced), + selected, - candidate, ~ configured

As you can see in the above config an intranet router synchs from two edge routers which in turn sync with public NTP servers over the internet.

This is working well, however SOMETIMES the intranet router shows unsynched even when both edge routers remains synched to the public servers and even when all of the three routers act as NTP MASTER.

Why is this happening ?

Ain't it the ntp master command intended to keep a router synched no matter how ?

I mean if the router losts synch for whatever reason, ain't the ntp master command supposed to switch INMEDIATLY to the 127.127.7.1 local hardware clock so the device keeps informing as still synched ?

What I'm missing here ?

PS: both edge routers are C1841s running c1841-advsecurityk9-mz.124-15.T11.bin

PS: intranet router is C1841 running c1841-advsecurityk9-mz.124-25b.bin

PS: ntp peer pointing to each edge still not configured

PS: on all configs no other related ntp command is used; such as ntp disable; which I tried on all edge's outside interfaces and it seems it is not working because whenever I put this command the router is no longer able to receive the public server respones (clearly seen while enabling ntp debug packets), and; if I got it right this command is supposed to block the interface as ntp server allowing it to act as an ntp client only

274
Views
0
Helpful
0
Replies