Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Blue

/opt/CSCOpx/bin/PSUCli.sh usage

So I downloaded

Cat6000.RME40.v2-0.zip and placed it in /var/temp/patch, but how do I install it with PSUCli.sh? I've tried with Cat6000.RME40.v2-0.zip as is, or unzipped:

/opt/CSCOpx/bin/PSUCli.sh -p rme -install -src /var/temp/patch/ Cat6000

It always comes back with

Services might be restarted, as a result of install operation

Would you like to continue ? ( Press y or n )

y

Proceeding with install..

Loaded psu.properties..

INFO: Installing for rme

Locking the package repository...

got all packages Repository

Checking Dependencies...

Warning: Cat6000(2.0):Consistency check failed for base package SharedDcmaCatOS

Warning: Cat6000(2.0):Consistency check failed for base package SharedInventoryCatSwitch

Warning: Cat6000(2.0):Consistency check failed for base package SharedSwimCAT

There are no Packages to be installed

Released the Lock...

then, when unzipped

/opt/CSCOpx/bin/PSUCli.sh -p rme -install -src /var/temp/patch/com Cat6000

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: /opt/CSCOpx/bin/PSUCli.sh usage

You MUST NEVER unzip device packages. The problem with installing the device package above is that it has dependencies which are not satisfied. It requires a later version of SharedDcmaCatOS, SharedInventoryCatSwitch, and SharedSwimCAT. You need to download those updates, or otherwise install them on your server before you can install the new Cat6000 package.

1 REPLY
Cisco Employee

Re: /opt/CSCOpx/bin/PSUCli.sh usage

You MUST NEVER unzip device packages. The problem with installing the device package above is that it has dependencies which are not satisfied. It requires a later version of SharedDcmaCatOS, SharedInventoryCatSwitch, and SharedSwimCAT. You need to download those updates, or otherwise install them on your server before you can install the new Cat6000 package.

187
Views
0
Helpful
1
Replies
CreatePlease to create content