Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Poor perfomance on LMS 4.2.4 topology map

Hi all

We've just installed LMS 4.2.4 on a virtual machine and are experiencing very poor performance. The specs are: 2 sockets with 4 cores each and with 16GB RAM. I've also added an extra drive with 32GB space for pagefile and moved the pagefile from default "c:" to "d:". As recommended from login, we have used the PTT to change from the default profile to the perftune profile.

We can log in and navigate around, but when we open the "Monitoring Tools -> Topology Services", it slows down to a very unacceptable speed. It takes between 20-30 minutes to get to the topology map!!! Off course we have checked our clients for issues. We are running the newest java-version, but have also tried an older version, that we used on our LMS 3.2.1. We have tried on 3 different clients, one of those with a clean installation, all with the same result.

Another obersvation is that after getting to the topology map and managing the view and setup, the memory usage of java, passes 500MB. Is that normal? We have around 500 devices so it shouldn't make such an impact on the perfomance.

I'm following Ciscos best practices.

Any ideas?

/Ditlev

Everyone's tags (4)
10 REPLIES
New Member

Poor perfomance on LMS 4.2.4 topology map

Am I really the only one with this problem?

New Member

Poor perfomance on LMS 4.2.4 topology map

Hi Ditlev

My customer is seeing slow performance on the LMS 4.2.3. A fter daemon restart is runs faster, but after some time it comes to be slow.

Another issue is that it's unable to save the topology map. If save the map and logout the LMS, when connect again the map does not show like the time it was saved.

Do you have this problem too?

Hall of Fame Super Silver

Poor perfomance on LMS 4.2.4 topology map

Not sure it's any consolation but I have used an LMS 4.2.4 running on a Windows server with lesser specs than yours but only a couple hundred devices. Topology performance was just fine (using Java 7 with latest updates).

New Member

Poor perfomance on LMS 4.2.4 topology map

Marvin

Do you have some hint to locate the cause of the LMS 4.2.3 topology map not being saved?

The installation mode is software appliance.

Hall of Fame Super Silver

Poor perfomance on LMS 4.2.4 topology map

Do your users have administrative level login on the local machines where the problem is observed? My check would be to try launching as local admin and see if that changes the behavior.

New Member

Poor perfomance on LMS 4.2.4 topology map

Hi Marvin

I will check your point, but I assume that the topology map is saved on the server and not on the local PC.

Am I wrong?

Hall of Fame Super Silver

Poor perfomance on LMS 4.2.4 topology map

They are stored on the server but the client Java dependencies are so tightly wound into the Topology tool that the most subtle details can throw a spanner into the works.

There's a reason why Topology didn't get into PI 2.0 - I suspect fixing all of this dependencies is a big part of it.

New Member

Poor perfomance on LMS 4.2.4 topology map

Marvin

After several tweeking on the topology map on LMS 4.2.3, removing dead devices from DCR and deleting all devices from the topology and recreate the map from scratch I could get an accetable topology map. During this work the 6500 VSS pair was shown as two boxes and after some Data Collections the VSS now shows as a single box.

At this time I see all link connections correct depicted except for two Eth Buses. These two Buses are related to software switchs on a VMware host, I think.

Sometimes I do need to run View > Relayout Circular to have the topology like saved before.

Next change will be upgrade to 4.2.4.

New Member

Poor perfomance on LMS 4.2.4 topology map

Hello, Cisco TAC installed the following patch that seems to have fixed my topology map saving issue: lms4-1.2.1-win-CSCub28888-1.0.zip. This was awhile ago and we have since upgraded to LMS 4.2.3.

New Member

Poor perfomance on LMS 4.2.4 topology map

Hi all

I contacted our Cisco-partner, who opened a case with TAC. It seems that it's a known problem that occurs with Java 7 update 25 and newer. Until Cisco finds a solution, you can solve the problem by unchecking/disabling the "certificate revocation check" in the Java console.

http://www.cisco.com/en/US/products/ps11640/products_tech_note09186a0080c15d10.shtml

Not perfect, but it works.

1295
Views
0
Helpful
10
Replies
CreatePlease login to create content