Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our beta test area to get started.

New Member

Prime Infra 2.0 : Warning message eval license even if permanent license is installed

Hi,

Customer has installed PI 2.0 with a eval license.

Since we have installed the permanent license, he stills have a warning message that says "The license for Lifecycle and Assurance features will expire in 50 days ..."

If we go to Administration-> License -> Sumary-> License, we can see something like that:

Serial Numberxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Lifecycle

97% (1 of 100 devices used)

-- Evaluation 50 days remaining

Assurance

0% (0 of 100 devices used)

-- Evaluation 50 days remaining

Collector

0% (Limit: 20 000; Avg: 0 fps)

-- Evaluation 50 days remaining

I would like to be sure that when evaluation license will expire, the permanent license will work.

Many thanks, Elisabeth

  • Network Management
Everyone's tags (2)
3 REPLIES
Hall of Fame Super Silver

Prime Infra 2.0 : Warning message eval license even if permanent

You might want to open a TAC case to walk you through the process but you can get rid of the warning issues via navigating down into the shell via CLI and removing the old evaluation license files.

You will need to stop and restart the license daemon for the server to re-parse with only the permananet licenses.

Bronze

Prime Infra 2.0 : Warning message eval license even if permanent

We've just rebuilt our PI 2.0 system and when I loaded the base lifecycle license the eval license was replaced so it sounds like it might not have added the permanent license.

New Member

This is covered by bug ID:

This is covered by bug ID: CSCul20922 - PI 2.0 shows evalution license  after restore, wont apply new licensing and CSCuj32554    After migration to PI 2.0 old licenses are not detected.

Workarounds for PI 2.0 are:

Become root on the PI 2.0 system

If you have not enabled root from the admin login, type root_enable and provide a password for root. Press enter and confirm the password. 

To become root from the admin login, type root, press enter and provide the password. 

You should get the ade# prompt. Continue with the instructions below...

cd /opt/CSCOlumos/licenses
mkdir old
mv *.lic ./old
mv restored.cfg ./old
run the script /opt/CSCOlumos/bin/license_post_restore.sh if it is restored server.

From the UI, login as root and install the licenses from this interface, BASE first, then remaining licenses
Logout for licenses to take effect
Login to verify licenses are installed. 

Lastly from the CLI, rm -rf /opt/CSCOlumos/licenses/old

Exit root login by typing exit, should return the Admin prompt. 

If you have issues or unsure about performing the workaround, open a TAC case for assistance. 

254
Views
0
Helpful
3
Replies