Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Prime Infrastructure 1.2 Appliance fails to start NCS

Hello all,

I've only experienced with PI virtual appliance and today i've received a brand new physical appliance to configure for a client. However, the device boots up normal but fails to start NCS which is not normal I believe.

Here’s the device information:

SPID: PRIME-NCS-APL-K9

VPID: V02

Serial: *

Here’s the log:

PRIME01990701/admin# ncs status

Health Monitor is running, with an error.

failed to start NCS on startup Health Monitor

Reporting Server is running

Ftp Server is running

Database server is running

Tftp Server is running

Matlab Server is running

NMS Server is stopped.

SAM Daemon is running ...

DA Daemon is running ...

Syslog Daemon is running ...

Status

PRIME01990701/admin# ncs start

Purging PurgeSAMPollerRecods

{Fri Sep 20 18:21:15 EST 2013} ===================================================

{Fri Sep 20 18:21:15 EST 2013} =========Issuing dbadmin -v start=================

{Fri Sep 20 18:21:16 EST 2013} =======executing delete sql script sam_poller_jobs_cleanup.sql====

{Fri Sep 20 18:21:17 EST 2013} ==========Issuing dbadmin -v stop=================

{Fri Sep 20 18:21:43 EST 2013} ===================================================

Completed purging SAMPoller Records

As first time is not present - removing .dbCreated

NCS processes - sam_daemon,da_daemon and syslog_daemon are already running; shut down before starting again, aborting...

Do I need to use a recovery disc to re-install? Please advise!

Thanks in advance.

J

Everyone's tags (2)
3 REPLIES
Cisco Employee

Prime Infrastructure 1.2 Appliance fails to start NCS

Hi

Looks like you are hitting bug CSCuf25963.

Please follow below instructions:

1/ Please login into the PI server via ssh or on console
2/ Please type ncs stop to stop services
3/ Please type root_enable to setup a root password
4/ Please type root to jump into the shell
5/ Please type vi /opt/CSCOlumos/conf/messaging.properties to enter into the vi editor
6/ Please change an IP address to proper one

# JMS Broker URL
broker.url=ssl://xxx.xxx.xxx.xxx:61617?wireFormat.maxInactivityDuration=0 <- in this line
broker.name=XMP_Message_Broker

7/ Please save the file and exit from root shell
8/ Please type ncs start and wait till all services are up and running

That could fix your issue.

Thanks

Mahavir

[Do rate helpful posts]

New Member

Prime Infrastructure 1.2 Appliance fails to start NCS

I got a response from CTAC. They say PI appliances are shipped with corrupted image and they recommend me to download ISO recovery image and recover the box.

I just realize that Cisco probably does not verify checksum before they put it on the appliance..

Anyways, thanks for your recommendation but i will just recover the appliance as per Cisco..

Thank you

J

New Member

Jiwon I'm facing same problem

Jiwon I'm facing same problem. Could you help kindly. My case the aappliance is stuck at init run level 3 and the ncs status command shows all services as stopped
1565
Views
0
Helpful
3
Replies
CreatePlease to create content