Cisco Support Community
Community Member

Prime Infrastructure 2.0 not discovering wired clients


My PI is not discovering all my wired clients.


Wired Client Status
Administration  >  Background Tasks >  Other Background Tasks  >  Wired Client Status
Last Execution Information

Start TimeEnd TimeElapsed Time (Seconds)ResultMessage
2014-Jan-14, 18:07:57 SAST 2014-Jan-14, 18:08:10 SAST 12 Failurejava.lang.NullPointerException
2014-Jan-14, 20:08:10 SAST 2014-Jan-14, 20:08:25 SAST 15 Failurejava.lang.NullPointerException
2014-Jan-14, 21:26:31 SAST 2014-Jan-14, 21:27:08 SAST 37 Failurejava.lang.NullPointerException
2014-Jan-14, 21:37:22 SAST 2014-Jan-14, 21:37:44 SAST 21 Failurejava.lang.NullPointerException
2014-Jan-14, 21:46:33 SAST 2014-Jan-14, 21:46:56 SAST 22 Failurejava.lang.NullPointerException
Task Details
DescriptionWired client status polling
Enabled Enabled
Interval (Hours)
Major Polling
Time of Day (hh:mm)
Time of Day (hh:mm)
Community Member

Did you ever get a resolution

Did you ever get a resolution to this issue?  This started happening to us a month ago or so.

We upgraded to PI 2.1 and the issue persists.

Community Member

We are getting this problem

We are getting this problem also.



Cisco Employee

Hi ,Prime infrastructure uses

Hi ,

Prime infrastructure uses MIB to collect the Mac address of the clients; this MIB collects
the information per vlan.

So we need to configure SNMP context for all vlans to view the wired client.

Try configure SNMP context on devices , then delete and re-add the device and check the issue.


For e.g:

snmp-server group gcobergroup v3 auth context vlan-1
snmp-server group gcobergroup v3 auth context vlan-71




****Ratings Encourages Contributors ***

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Community Member

I got the situation that

I got the situation that "Wired Client Status" backgroundtest is sometimes working, sometime not. Does anyone know how to debug this? Since the switch configuration has not changed, I need to find the reason for this.

Community Member

It solved my problem too ...

It solved my problem too ... Thanks

Community Member

I also saw this suggested

I also saw this suggested solution, so you don't have to list every VLAN, or try to sync contexts as you create and delete VLANs:

snmp-server group <whateveryourgroup> v3 auth context vlan- match prefix
CreatePlease to create content