Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Prime Infrastructure 2.0 Software IOS deployment problems

When I try to deploy an IOS using the software deployment in Cisco PI 2.0 the jobs always fail. I have tried many different configurations and even switched flash cards but nothing works. The TFTP/SCP jobs always fail. Doing a "show flash:" I can see the image begin to copy, but it suddenly disappears and the job fails.

Any help would be very appreciated, this is very frustrating!!

Here is the failure message:

SWIM1125: Failed to copy the image to Flash due to the reason - copyUnknownFailure :failure unknown. Retry the operation. If the problem persists, check the Bug Toolkit application for any known issues on the running image version.Error loading image to flash.Image Copy Operation Failed

Thanks very much.

2 REPLIES
New Member

Prime Infrastructure 2.0 Software IOS deployment problems

What image file are you trying to deploy?

From what I've tried, it seems you need the default .bin files not the .tar files.

New Member

Prime Infrastructure 2.0 Software IOS deployment problems

I solved my issue by running looking at the debug output on the 2811 router I was pushing the IOS (.bin file) to. I noticed that the TFTP traffic would simply stop without warning and seemingly for no reason. I gave up on the TFTP and had to configure the router for SCP instead (aaa new-model, etc.). The image would successfully copy from the prime server to flash after that.

The failure output from prime was very unhelpful for both tftp and scp failures. It wasn't until I did some SCP configuration reading that I realized I had SCP configured wrong. Still no idea why the TFTP wouldn't work.

574
Views
0
Helpful
2
Replies