Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Prime LMS4.2 Compliance Policy and Psirt/Eox Job Failure

Our Prime LMS 4.2's Compliance Policy and Psirt/Eox Job keeps failing since one day, no matter whether I select to use Cisco.com or Local as an option.

When using Cisco.com as the option, reported error:

Job Summary
Description:System Compliance Policy and Psirt/Eox Job
Start Time:Mar 10 2014 15:35:00
LMS Server Name :LMSServer.company.com
Job Failure Reason:Either connection failed to cisco.com or the CCO user credentials are incorrect
Compliance Policy Update Status:Either connection failed to cisco.com or the CCO user credentials are incorrect
E-mail has been sent to:admin@company.com
Psirt/Eox Update Status:Succeeded
RunStat:Failed
End Time:Mar 10 2014 15:42:36
Schedule Type:Daily
Log File:/var/adm/CSCOpx/files/rme/jobs/inventory/reports/jobs/1349.7/1349.7.log
Owner:admin

 

I use the same LMS server to download Cisco IOS from Cisco.com so I assume the connection and credentials should be fine? I'm not sure what RunStat Failed means, while Psirt/Eox Update Status Succeeded?

 

I tried folowwing the guide http://www.cisco.com/c/en/us/td/docs/net_mgmt/ciscoworks_lan_management_solution/4-2/user/guide/admin/admin/collection.html#wp1231096 to manually run the report. Both .zip files downloaded successfully and the current files under my Linux VM /var/adm/CSCOpx/files/rme/jobs/inventory/reports/EOX_PSIRT/local_xml are:

 

EOX_SOFTWARE.zip  PSIRT_EOX_OFFLINE.txt  eox_soft.xml

Then I tried Local as report option, however the report email contains a link which can not be opened. When I clicked on it, the web browser says "The webpage you are viewing is trying to close the tab."

 

I've noticed some error in the log files, doesn't matter whether it was running using Cisco.com or Local, the errors are pretty much the same:

[ Mon Mar 10  15:37:41 EST 2014 ],ERROR,[main],com.cisco.nm.rmeng.inventory.reports.util.LocalXMLParser,getFileName,296,Here *****IOS_120.xml<dataset>
[ Mon Mar 10  15:37:45 EST 2014 ],ERROR,[main],com.cisco.nm.rmeng.inventory.reports.util.LocalXMLParser,getFileName,296,Here *****IOS_122.xml<dataset>
[ Mon Mar 10  15:37:51 EST 2014 ],ERROR,[main],com.cisco.nm.rmeng.inventory.reports.util.LocalXMLParser,getFileName,296,Here *****IOS_123.xml<dataset>
[ Mon Mar 10  15:37:57 EST 2014 ],ERROR,[main],com.cisco.nm.rmeng.inventory.reports.util.LocalXMLParser,getFileName,296,Here *****IOS_124.xml<dataset>
[ Mon Mar 10  15:38:01 EST 2014 ],ERROR,[main],com.cisco.nm.rmeng.inventory.reports.util.LocalXMLParser,getFileName,296,Here *****IOS_150.xml<dataset>
[ Mon Mar 10  15:38:01 EST 2014 ],ERROR,[main],com.cisco.nm.rmeng.inventory.reports.util.LocalXMLParser,getFileName,296,Here *****PSIRT_DETAILS.xml<data>

[ Mon Mar 10  15:41:49 EST 2014 ],ERROR,[main],com.cisco.nm.rmeng.inventory.reports.util.LocalXMLParser,getFileName,296,Here *****eox_card.xml<data>
[ Mon Mar 10  15:41:49 EST 2014 ],ERROR,[main],com.cisco.nm.rmeng.inventory.reports.util.LocalXMLParser,getFileName,296,Here *****eox_device.xml<data>

[ Mon Mar 10  15:42:36 EST 2014 ],ERROR,[main],com.cisco.nm.rmeng.inventory.reports.job.SystemJobExecutor,main,?,IRException is Either connection failed to cisco.com or the CCO user credentials are incorrectcom.cisco.nm.rmeng.inventory.reports.util.IRException: Either connection failed to cisco.com or the CCO user credentials are incorrect
    at com.cisco.nm.rmeng.inventory.reports.util.EOXSoftwareXMLParser.GetPolicyUpdatesURLFromPSUApi(Unknown Source)
    at com.cisco.nm.rmeng.inventory.reports.util.EOXSoftwareXMLParser.fetchPolicyUpdatesJar(Unknown Source)
    at com.cisco.nm.rmeng.inventory.reports.job.SystemJobExecutor.main(Unknown Source)

 

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Hi, you seems to be hitting

Hi,

 

you seems to be hitting the below BUg

LMS4.2.1: System Psirt Job failing
CSCua64861
 
Applicable to 4.2 as well.
 
Thanks-
Afroz
****Ratings Encourages Contributors****
Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
2 REPLIES
Cisco Employee

Hi, you seems to be hitting

Hi,

 

you seems to be hitting the below BUg

LMS4.2.1: System Psirt Job failing
CSCua64861
 
Applicable to 4.2 as well.
 
Thanks-
Afroz
****Ratings Encourages Contributors****
Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Hall of Fame Super Silver

I can confirm the reports

I can confirm the reports work fine on LMS 4.2.4. I just checked two different systems and both are working as designed.

131
Views
0
Helpful
2
Replies