Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Prime upgrade to 2.0 failed

Hi Folks, I did a prime upgrade to 2.0 from the patch PI_1_3_0_20-Update.4-16.tar.gz and it failed.... and i cannot do ncs start... But i guess i dont have the backup as well... but its asking to restore... What am thinking is am i supposed to restore to old patch or if there is something else to which I 'am supposed to restore...

Below is the logs for your reference....

==================

CISCOPRIME/admin# ncs start

ERROR: The last upgrade operation was unsuccessful. See dbadmin_StdOut.log for details. To recover, reinstall the server and restore the saved backup data.

CISCOPRIME/admin# ^C

--------------------------------------

CISCOPRIME/admin# dir disk:/defaultRepo

Directory of disk:/defaultRepo

3178586084 Feb 22 2014 11:54:53  backup-20140222-1130.tar.gpg

3304350817 Feb 25 2014 08:37:52  backup-20140225-0812.tar.gpg

----------------------------------------

CISCOPRIME/admin# restore backup-20140225-0812.tar.gpg repository defaultRepo

Restore will perform a reboot to successfully complete. Continue? (yes/no) [yes] ? yes

DO NOT press ^C while the restoration is in progress

Aborting restore with a ^C may leave the system in a unrecoverable state

Initiating restore.  Please wait...

  Restore Started at 02/26/14 18:50:37

  Stage 1 of 9: Transferring backup file ...

  -- completed at 02/26/14 18:50:50

  Stage 2 of 9: Decrypting backup file ...

  -- completed at  02/26/14 18:52:47

  Stage 3 of 9: Unpacking backup file ...

ERROR: Backup you are trying to restore is application backup. Please retry restore with an appliance backup.

% System restore failed

CISCOPRIME/admin# ^C


2 REPLIES
Cisco Employee

Re: Prime upgrade to 2.0 failed

Was the PI 1.3 OVA install a small OVA?

If so, you would need to build an Express or larger PI 2.0 OVA per:

Note If you are upgrading from Prime Infrastructure 1.x small virtual machine, you should create a new virtual machine with the Express OVA, back up your existing small virtual machine, and then restore it on the new virtual machine. You can delete the old small virtual machine after the new virtual machine is fully operational. Inline upgrade of the

small virtual machine is not supported.

Cisco Prime Infrastructure 2.0 Quick Start Guide Requirements

http://www.cisco.com/en/US/customer/docs/net_mgmt/prime/infrastructure/2.0/quickstart/guide/cpi_qsg.html#wp56675

In-place Upgrade

http://www.cisco.com/en/US/customer/docs/net_mgmt/prime/infrastructure/2.0/quickstart/guide/cpi_qsg.html#wp66122

Mostly it seems to be a corrupt DB. You can download and install a fresh PI 2.0 and later, if you have old backup, try to restore data from it.

-Thanks
Vinod
**Rating Encourages contributors, and its really free. **

-Thanks Vinod **Rating Encourages contributors, and its really free. **
New Member

Re: Prime upgrade to 2.0 failed

Hi Vinod, Its not on Virtual machine, instead on CISCO Appliance itself....  I can console into the device and see the current version running 2.0, but i cannot access via SSH or HTTPS because NCS status shows services are stopped and am unable to start it as it is giving the error saying the upgrade failed and need to restore... I have copied the logs above..

Right now i have in my mind is to try restoring the box to previous working patch PI_1_3_0_20-Update.4-16.tar.gz, which I could still see it in the flash... If it gets restored then well and good...

327
Views
0
Helpful
2
Replies
CreatePlease to create content