Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

problem with ANIServer

Hi,

I was having issues the crmdmgtd file, and had to reset the casuser password. After that daemon started succesfully, but ANIServer did not.

Here is the pdshow for the reference..

"

Process= ANIDbEngine

State = Program started - No mgt msgs received

Pid = 800

RC = 0

Signo = 0

Start = N/A

Stop = Not applicable

Core = Not applicable

Info = Service was already running

Process= ANIServer

State = Failed to run

Pid = 0

RC = -2

Signo = 1073741822

Start = N/A

Stop = 09/20/2007 08:26:50 AM

Core = Not applicable

Info = Application failed or was registered incorrectly.

"

Please help me understand this and resovle...

1 ACCEPTED SOLUTION

Accepted Solutions

Re: problem with ANIServer

good news!

but I am wondering how IPM blocked the reinit process for ani ...

You must not worry about the other processes. They will be started when they are needed as they are responsible for some tasks in LMS which can be configured to run periodically or which are used as periodic background processes.

15 REPLIES
Cisco Employee

Re: problem with ANIServer

Is the process EDS also running?

Can you try to stop ANIDbEngine via pdterm, then start it via pdexec and the same with ANIServer?

New Member

Re: problem with ANIServer

:\>pdshow EDS

Process= EDS

State = Running normally

Pid = 5056

RC = 0

Signo = 0

Start = 09/21/2007 08:40:03 AM

Stop = Not applicable

Core = Not applicable

Info = Initialization complete

I did pdterm and pdexec, for both ANIDbEngine and ANIServer, but no luck..

Process= ANIServer

State = Failed to run

Pid = 0

RC = -2

Signo = 1073741822

Start = N/A

Stop = 09/21/2007 08:26:43 AM

Core = Not applicable

Info = Application failed or was registered incorrectly.

New Member

Re: problem with ANIServer

i am still having the same issue... ANIServer service is not working...

Application failed or was registered incorrectly.

Re: problem with ANIServer

what gives "pdreg -l ANIServer"

please provide the complete output of "pdshow"

New Member

Re: problem with ANIServer

C:\>pdreg -l ANIServer

Process = ANIServer

Path = C:\PROGRA~1\CSCOpx\campus\jre\bin\java.exe

Flags = -Xbootclasspath:C:\PROGRA~1\CSCOpx\www\classpath\vbjorb.j

ar,C:\PROGRA~1\CSCOpx\campus\jre\lib\rt.jar,C:\PROGRA~1\CSCOpx\campus\jre\lib\i1

8n.jar -Xminf0.1 -Xmaxf0.1 -Djava.class.path=C:\PROGRA~1\CSCOpx\campus\www\class

path\jndi.jar,C:\PROGRA~1\CSCOpx\campus\www\classpath\providerutil.jar,C:\PROGRA

~1\CSCOpx\campus\www\classpath\dns.jar,C:\PROGRA~1\CSCOpx\campus\lib\classpath,C

:\PROGRA~1\CSCOpx\campus\www\classpath,C:\PROGRA~1\CSCOpx\lib\classpath,C:\PROGR

A~1\CSCOpx\www\classpath,C:\PROGRA~1\CSCOpx\lib\classpath\servlet.jar -Djava.lib

rary.path=C:\PROGRA~1\CSCOpx\bin,C:\PROGRA~1\CSCOpx\campus\bin -Dvbroker.orb.gcT

imeout=90 -Xrs -Xmx512m com.cisco.nm.ani.server.frontend.AniMain

Startup = Started automatically at boot.

Dependencies = EDS ANIDbEngine

==============================================

Output of pdshow is attached...

Re: problem with ANIServer

what happened on 9/25 around 8:40 am ? Some central DFM processes get stopped there. After you have reset casuser as Joe said, have you restarted the LMS processes? If yes, have you done it through the Web-Gui or CLI?

New Member

Re: problem with ANIServer

i am having seperate issues with DFM, and i myself closed the DFM services, nothing related to ANIServer issue..

When i reset the casuser password, i used "net stop/start crmdmgtd" on CLI.

Re: problem with ANIServer

Could you please stop the services with 'net stop crmdmgtd', check in TaskManager that every process has been stopped (no dbeng or dbsrv service anymore and no cwjava). Then restart with 'net start cromdmgtd'. After some time (around 10 min) get the output of 'pdshow' and please post it along with %NMSROOT%\log\ANIServer.log, where %NMSROOT% is the root install directory.

New Member

Re: problem with ANIServer

I haved attached the all the required files...

Re: problem with ANIServer

I see this line:

ani ERROR DBConnection$ConnectionCreator: Failed to establish DB connectivity because: java.sql.SQLException: JZ00L: Login failed

along with a CORBA failure; I am not sure if the last is related to the first, so try to reset the ANI database password with the following procedure:

# Stop the processes again

net stop crmdmgtd

cd NMSROOT\bin

.\perl .\dbpasswd.pl dsn=ani npwd=

# enter the new password without the brackets

# restart the processes

net start crmdmgtd

# check if ANIServer is coming up now

pdshow ANIServer

New Member

Re: problem with ANIServer

here is the output...

=================

C:\Program Files\CSCOpx\bin>.\perl .\dbpasswd.pl dsn=ani npwd=casuser

Start changing password for database 'ani'...

Starting database engine 'ani'

Starting database engine aniEng

ERROR: Failed to connect to database 'ani' with current password.

Trying the factory password for the database 'ani'.

ERROR: Failed to update new userinfo into database.

Stopping database engine aniEng

Unable to stop Adaptive Server Anywhere Agent -- Invalid user ID or password.

ERROR: Failed change password for database 'ani'.

Please see log file C:\PROGRA~1\CSCOpx\log\dbpwdChange.log for details.

====================================

i have attached the dbpwdChange.log.

New Member

Re: problem with ANIServer

output of pdshow is attached...

Also, i tried using reinitdb for reinitialize the ANIDb, but got following

===============================

C:\Program Files\CSCOpx\campus\bin>perl reinitdb.pl

This will erase all data from the database. Are you sure [y/n] ?y

START reinitdb...

Dropping database tables Wbu* ...

ani:::::Wbu

ERROR DropTable: Failed to establish DB connectivity because: java.sql.SQLExcept

ion: JZ006: Caught IOException: java.net.ConnectException: Connection refused: c

onnect

Reinitdb terminated with errors.

C:\Program Files\CSCOpx\campus\bin>perl reinitdb.pl -restore

This will restore your original database and your current data will be lost.

Are you sure [y/n] ?y

WARNING: Could not delete file C:\PROGRA~1\CSCOpx\databases\ani\ani.db

StandardDbRegistration .

Start changing password for database 'ani'...

Starting database engine 'ani'

Starting database engine aniEng

ERROR: Failed to start database engine for database 'ani'

ERROR: Failed change password for database 'ani'.

Please see log file C:\PROGRA~1\CSCOpx\log\dbpwdChange.log for details.

ani database initialization failed.

==================================

Re: problem with ANIServer

Did you have verified that all LMS processes were down before using

C:\Program Files\CSCOpx\campus\bin>perl reinitdb.pl -restore ?

If yes, stop the prcocesses again and check if you have an ani.log file in NMSROOT\databases\ani. If it is there, remove it and execute in a dos box

NMSROOT\objects\db\win32\dbsrv7 -f ani.db

try restarting crmdmgtd.

If this still does not work or you do not have the ani.log file, do the following:

open the Windows services panel and change the 'Startup Type' for 'CiscoWorks Daemon Manager' from automatic to manual (do not change any other parameter for CiscoWorks related services! - I assume none of these parameters has been changed before), reboot your system and retry to reinit the ani db, if it is successful, reset the 'Startup Type' for the Daemon Manager to automatic, and start the processes (net start crmdmgtd).

If ANIServer and ANIDbEngine is still not running, please send the following file NMSROOT\www\classpath\cisco\nm\cmf\DBService\DBserver.properties

New Member

Re: problem with ANIServer

YESS.... Got it..

Apperently, there was something tied with IPM services... Because even i was following the process mentioned by Mermal, it was not letting me reinit the db. call it luck, or my frustration that i stopped all the IPM services as well, and , reinit the db with restore option. and here you go. Thanks God that now i have set a single password for all the db services...

I must say thanks to you Mermal,because i was on edge of reinstalling the whole server, but his help and guidance solved my problem..

Here is one more thing, so i might be aware of any consequences if there are any..

I have

AvTrimmer

ConfigChangeDetector

ConfigPurge

ConfigUpdate

EDS-TR

InvChangeDetector

which do not start atutomatically.. even if i start them manually, they get back to stop..

Is there any thing that i need to worry about, or is it something normal and avoidable?

Re: problem with ANIServer

good news!

but I am wondering how IPM blocked the reinit process for ani ...

You must not worry about the other processes. They will be started when they are needed as they are responsible for some tasks in LMS which can be configured to run periodically or which are used as periodic background processes.

351
Views
5
Helpful
15
Replies
CreatePlease login to create content