Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem with arhive management with SSH!

Hello, if someone knows how to handle it, please replay.

I have issue with arhive management in RME 4.3.0 and 2960 LANLITE switches.

It can not poll or fetch configuration from these switches or deploy with NetConfig.

Transport protocol for archive management and NetConfig is SSH. SSH on switches

is configured correctly as I can connect with normal client. I investigated about this problem,

it seems like that the problem is with SSH authentication metod. It shows me some

kinde of error for SSH : unknown authentication metod: keyboard-interactive. Here

is some output from log file :

[ Thu Apr 22  10:42:53 CEST 2010 ],ERROR,[Thread-2818],com.cisco.nm.xms.xdi.transport.cmdsvc.LogAdapter,error,19,Unknown authentication method: keyboard-interactive
[ Thu Apr 22  10:42:57 CEST 2010 ],ERROR,[Thread-2818],com.cisco.nm.rmeng.dcma.configmanager.ConfigManager,updateArchiveForDevice,1355,PRIMARY STARTUP Config fetch Failed for xxx.xxxx device

[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.xms.xdi.pkgs.SharedDcmaGeneric.transport.GenericConfigOperator,fetchConfig,70,I am here
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.xms.xdi.pkgs.SharedDcmaGeneric.transport.GenericCliOperator,registerPlatform,95,Calling new GenericPlatform()
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.xms.xdi.pkgs.SharedDcmaGeneric.transport.GenericPlatform,<init>,23,setting GP user and pass prompts
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.xms.xdi.pkgs.SharedDcmaGeneric.transport.GenericPlatform,<init>,30,registering generic platform
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.xms.xdi.pkgs.SharedDcmaGeneric.transport.GenericPlatform,<init>,32,registered generic platform
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.rmeng.util.rmedaa.RMEDeviceContext,getCmdSvc,1537,Inside RMEDeviceContext's getCmdSvc ....
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.rmeng.util.rmedaa.RMEDeviceContext,getCmdSvc,1547,Protocol and Platforms passed = SSH , GEN
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.rmeng.util.rmedaa.RMEDeviceContext,getCmdSvc,1571,Iam inside ssh ....
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.rmeng.util.rmedaa.RMEDeviceContext,getCmdSvc,1573,Initial time_out : 0
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.rmeng.util.rmedaa.RMEDeviceContext,getCmdSvc,1583,Computed time_out : 36
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.rmeng.util.rmedaa.RMEDeviceContext,getCmdSvc,1599,After computing time_out : 36
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.rmeng.util.rmedaa.RMEDeviceContext,getSshCmdSvc,1637,inside getSshCmdSvc with timeout : 36000
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.rmeng.util.rmedaa.RMEDeviceContext,getSshProtocols,1743,Inside getsshprotocols with time out : 36000
[ Thu Apr 22  10:42:57 CEST 2010 ],INFO ,[Thread-2818],com.cisco.nm.rmeng.util.rmedaa.RMEDeviceContext,getSshCmdSvc,1651,SSH2 is running
[ Thu Apr 22  10:42:59 CEST 2010 ],ERROR,[Thread-2818],com.cisco.nm.xms.xdi.transport.cmdsvc.LogAdapter,error,19,Unknown authentication method: keyboard-interactive
[ Thu Apr 22  10:43:03 CEST 2010 ],ERROR,[Thread-2818],com.cisco.nm.rmeng.dcma.configmanager.ConfigManager,updateArchiveForDevice,1355,PRIMARY RUNNING Config fetch Failed for xxxx.xxxx device

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Problem with arhive management with SSH!

It does not appear this device is supported by LMS yet.  What is its sysObjectID?

4 REPLIES
Cisco Employee

Re: Problem with arhive management with SSH!

This isn't a real error.  The most likely cause is wrong credentials for the device in DCR.  Enable Archive Mgmt Service debugging undeR

RME > Admin > System Preferences > Application Log Level Settings, then re-run the Sync Archive job, and post the dcmaservice.log.

New Member

Re: Problem with arhive management with SSH!

Hello Joe and thanks for your time,

I checked out credentials in DCR as you said and

they are correct. Here you are some output from dcmaservice log

with debugging level on ArchiveMagement.

Write me if you find out something,

thanks in advance.

Cisco Employee

Re: Problem with arhive management with SSH!

It does not appear this device is supported by LMS yet.  What is its sysObjectID?

New Member

Re: Problem with arhive management with SSH!

Hello Joe and thanks for your time.

I checked out immediately for device support in RME as you said,

and you were right, it is not supported. I connected to cisco.com and

download new device packages for catalyst 2960. Problem solved, forks fine!

Thanks a lot and I will give you "correct answer" and few points from me

for solving my problem.

617
Views
0
Helpful
4
Replies
CreatePlease to create content