Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem with connecting to ANIserver6.0

hi;

when I try to open the topology services I recieve the error Cannot connect to the ANIserver .... even when I am on the server itself .

I've found out it is due to my DNS problem, here is the scenario;

I installed the LMS on the server just before I joined it to the domain, after that I changed the name of the server and I joined it to the domain.

I was facing with the problem disabling to connect to ANIServer , so that I run the name change script on the server , even after that the problem

persists, as I click on CISCOWORKS shortcut on the desktop it is trying to open the wrong URL which is http://win-fktcprvq4r6:1741/ instead of the name which is the name of the server . attached is my pdshow and the snapshot of my desktop showing the wrong URL .

1 ACCEPTED SOLUTION

Accepted Solutions

Problem with connecting to ANIserver6.0

this looks ok, assuming lms-forsat is still the hostname of your server.

Could you please again describe the steps you do to access the page that throws the error and illustrate it with screenshots so that we can get a clear picture of the failure.

21 REPLIES

Problem with connecting to ANIserver6.0

It is indeed a pitty that many errors in LMS just produce a broad  list of possible issues, not related at all to the current situation.

It might as well just say 'fault'

Where in this case there is no issue whatsoever to say something like:

  • Can't resolve hostname:'win-fktcprvq4r6' to an IP addres.
  • Can't connect to ANIServer on 'win-fktcprvq4r6'  on TCP port '43242'.
  • etc...

Cheers,

Michel

Problem with connecting to ANIserver6.0

the hostname in shortcut will not be changed from the changehostname.pl script, you have to do it manually.

You have to create your own shortcut.

Right-click on the Desktop > new > shortcut

    location: http://new-lmsServer:1741

    name: Cisco Prime (or CiscoWorks)

finish

right-click on the new shortcut, open Properties

open the tab: Webdocument

    change icon > Browse

        point to: NMSROOT\MDC\etc\ciscoWorks.ico

with NMSROOT beining your installation path of LMS (e.g. C:\Progra~1\CSCOpx)

New Member

Problem with connecting to ANIserver6.0

Dear martin;

Even if I change that I dont think if my problem solved , cause my problem is; when I try to open topology services in Campus Manager, I got that error .

thank you .

Problem with connecting to ANIserver6.0

sorry I didn't understood correctly;

on the LMS server, what does

    NMSROOT\bin\resolver.pl newLMSServer_Name

    NMSROOT\bin\resolver.pl LMSserver_IP

gives back?

New Member

Problem with connecting to ANIserver6.0

I have changed the name of the server again and run the changehostname script, the problem sloved !!!

but when I run the two commands you have mentionedm,the results are nothing.

Problem with connecting to ANIserver6.0

From another pc, can you connect to the aniserver where using the current name of the server?

If not goto java control panel, Advanced tab. Enable logging and show console.

Post the log from the console here.

On the server itself,  can you connect to the aniserver where using the current name of the server?

In IE create a bookmark, delete the ciscoworks icon from the desktop, drag the ciscoworks from your favourites to the desktop

Cheers,

Michel

New Member

Problem with connecting to ANIserver6.0

As I just replyed to Martin the problem solved but I dont know why should I have to change the name again !!

but to answer you I have to say that the problem was either on client and the server itself

thank you all guys ;-)

New Member

Re: Problem with connecting to ANIserver6.0

Dear Michel;

Now I have new problem, I can start  the topology services from the server itself, but I just couldn't open from other servers or client , I can't stand recieving this kind of problem. I have attached the error

Problem with connecting to ANIserver6.0

From that pc can you ping 'forsat'?

Can you enable java debug as I described earlier and post that log here?

Cheers

Michel

New Member

Re: Problem with connecting to ANIserver6.0

sure I can ping forsat,

I have attached the java log file ,

thank you .

Re: Problem with connecting to ANIserver6.0

Ali

For now it doesn't work because the servername is main-cs-1 not forsat

I think if you create a hosts file entry on your pc with the IP of forsat and the name  main-cs-1 the connection should be possible.

*********************************************

initializeSwing...

ClientModule.installAllModules...

performAniLogin...

Session id is alpha-numeric, Exception:For input string: "515A559F12E0E53BD43D386F47BFB88B"

_Orb=org.jacorb.orb.ORB@18a8ae7

org.omg.CORBA.TRANSIENT: Retries exceeded, couldn't reconnect to main-cs-1:42342

    at org.jacorb.orb.iiop.ClientIIOPConnection.connect(ClientIIOPConnection.java:232)

    at org.jacorb.orb.giop.GIOPConnection.sendMessage(GIOPConnection.java:934)

    at org.jacorb.orb.giop.GIOPConnection.sendRequest(GIOPConnection.java:900)

    at org.jacorb.orb.giop.ClientConnection.sendRequest(ClientConnection.java:323)

Cheers,

Michel

New Member

Re: Problem with connecting to ANIserver6.0

thank you,

As I mentioned earlier I have changed the name of the server and I ran the

changehostname script, on that . I wonder if there is a way to change that name too and not to relate the IP with the previous hostname.

thank you very much

Re: Problem with connecting to ANIserver6.0

I have to say that I don't understand that the server is looking for its old name after you run the changehostname script......

Could it be some processes remained running after you did a net stop crmdmgtd? Make sure all lms services are on manual startup except crmdmgtd, syslog, tftp and RCP service.

You may want to put the crmdmgtd to manual as well and reboot the server to make sure no files are looked when you run the changehostname script.

Cheers,

Michel

New Member

Re: Problem with connecting to ANIserver6.0

I dont have the service you've mentioned: "crmdmgtd" . in the services .

where can I find that ?

Problem with connecting to ANIserver6.0

It is the name of the ciscoworks daemon manager.

Ciscoworks Administrative Service that starts the other services 

Cheers,

Michel

New Member

Problem with connecting to ANIserver6.0

I have stoped that service , turned it to manual , and I change the host name again and ran the changehostname script , but after all when I try to open the ANI server I got the same problem, and the intresting part is I change the hostname from forsat to lms-forsat but still it is looking for main-cs-1  !!!!

Problem with connecting to ANIserver6.0

I must admit I have not used that script a lot.

Since changing the hostname was more difficult in the past I always set it right before I install.

I guess you can open a tac case that the scritp doesn't work.

Or you can reinstall once the names are good.

Cheers,

Michel.

Problem with connecting to ANIserver6.0

have you ever tried to clear all caches after launching the script?

If not, logout of LMS, clear the browser cache, close ALL browser windows.

To clear the java cache, go to Start > Control Panel > Programs > Java

    open the "General" tab, open "Settings" and click on "Delete Files"

also have a look in C:\Windows\system32\drivers\etc\hosts file if there is still an entry that points to the old hostname,-  if yes, remove it

now login to LMS and retry to open the topology map..

if the above does not help, make a backup of the following file:

NMSROOT\campus\etc\cwsi\ANIServer.properties

now, look for theses entries:

    AniName=ANIServer7.0-LMSSERVER

    DFMPoller.DFMServerList=http://LMSSERVER:1741,

(with LMSSERVER being YOUR NEW server hostname)

if this is not the case, change it to the new hostname.

If you need to change any of the entries, restart LMS ("net stop crmdmgtd" wait until this command has finished, then issue "net start crmdmgt")

If this still does not help, login to LMS and point the browser to this URL, post the output:

http://:1741/JSP/CAMPUS/ANI/GetAniName.jsp?dmgrName=ANIServer

(with being the IP of your LMS Server)

New Member

Problem with connecting to ANIserver6.0

I have done all you kindly mentioned to me , but non of them coould solve the problem

and the result for the

http://:1741/JSP/CAMPUS/ANI/GetAniName.jsp?dmgrName=ANIServer,   is  : ANIServer6.0-lms-forsat

thank you

Problem with connecting to ANIserver6.0

this looks ok, assuming lms-forsat is still the hostname of your server.

Could you please again describe the steps you do to access the page that throws the error and illustrate it with screenshots so that we can get a clear picture of the failure.

New Member

Problem with connecting to ANIserver6.0

I finaly reinstalled the server, changehostname script did not work well,

thank you all

993
Views
0
Helpful
21
Replies
CreatePlease login to create content