Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started.

New Member

Problem with DHCP config for SAA

I'm using SAA/RTR to monitor our network, and I'm trying to set up DHCP checks. However, every time the operational status shows as "Operation failed". The DHCP server has sent an offer - I've checked its log - but the router isn't happy with it. If I turn on debug for rtr trace and error, and for dhcp detail, the router shows an offer arriving, but says "XID did not match" and "Received a BOOTREP pkt Not for us". This happens whether I set the source and destination addresses on the check, or just leave them as default. I've tried running it on an old 3640 router running 12.3(14)T7 (only one interface is use) and on a 3750 running 12.2(25)SEE3 (several SVI interfaces in use). The DHCP server is an InfoBlox, which basically runs ISC DHCP. It does all our DHCP serving, and I've never seen this problem with it before. There will always be a DHCP relay agent in the path, but that will be a Cisco router too. I've tried turning off the broadcast flag for DHCP requests, but that makes no difference. I'm not telling it to add any options to the DHCP requests, so the definition is either "type dhcp" or "type dhcp source <interface-address> dest <server-address>". Any help would be much appreciated


  • Network Management
Cisco Employee

Re: Problem with DHCP config for SAA

I cannot reproduce. First, 12.2(25)SEE3 is not supported for IP SLA (SAA/RTR). While the commands are present, you will need to upgrade to 12.2(40)SE to get support.

I have a 3560 running 12.2(50)SE1 and a FreeBSD server running isc-dhcp 3.0.7. I have configured an IP SLA collector as:

ip sla 12


timeout 10000

And I am getting constant success. It sounds like this may be a compatibility issue with your version/implementation if isc-dhcp and IOS DHCP.

A sniffer trace of the transaction could indicate exactly where things are going wrong.

New Member

Re: Problem with DHCP config for SAA

You were absolutely right. I've also installed 12.2(50)SE1, and the same DHCP commands are now working fine. Oddly, I'm running RTR on other switches with the older release, and it seems to be fine, but I'm not using DHCP probes. Anyway, many thanks for your help