Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

Problem with queuing


I'm doing some tests involving measurement of queuing mechanisms performance on Cisco 2620XM routers. During the tests I transmit UDP traffic between Iperf client and server installed on two workstations. Another two pairs of PCs have configured softphone software and transmit RTP packets between each other. There are two routers in my topology and on both interfaces connecting the routers I configured policy map in order to limit bandwidth to 1.1Mb/s. The reason for this is that the link will react as a bottleneck and will force routers to use queues. Iperf client transmits UDP data with 1.05 Mb/s so UDP transmission alone doesn't cause any packets being dropped. However when I start conversation between two softphones the bandwidth is exceeded and router drops some packets.

My task is to measure performance of hardware queuing and various software queuing techniques such as FIFO, PQ, CQ and WFQ. To do that I capture packets with Wireshark, which gives me statistics for RTP sessions so I know how many RTP packets are being dropped etc. I've done some initial tests and I faced a problem where I receive the same results for different queuing configured on routers. I always configure queuing with the same parameters on all interfaces and I use only Fast Ethernet interfaces. When I set default software queuing (FIFO) on all interfaces to zero for inbound and outbound queues in order to measure only hardware queuing performance I received the same result as with software FIFO enabled (default values - 75 inbound and 40 outbound). Moreover, when I've done another test with default PQ (high - 20, medium - 40, normal - 60 and slow - 80)  enabled on all interfaces I still have almost the same result. For PQ test I configured ACLs on routers and I gave the highest priority to PCs transmitting RTP, medium priority to PCs transmitting UDP and normal for any other data packet. I even changed the hight priority queue size to 1000 and other to 20 and results are still almost the same!! I didn't try any other queuing so far but I gues it will be the same. I think that with such huge high priority queue there should be no RTP packets dropped but its the same as for other tests.

Does any one know what to make it work properly because I assume there is something wrong.

I can provide additional information. Just ask if you need it.

Thanks for any help.

CreatePlease to create content