Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Problem with Software Distribution in LMS 3.2

LMS 3.2 on Solaris 10

I'm trying to distribute IOS images via Software Mgmt. I'm getting the following error on step 2 - View Recommendations.

"SWIM0087: Recommendation module timed out while waiting for the procedure to complete.
Either the device had many images to process or one of the services used by this application is not responding.
Either fine-tune the administrative preferences to filter out any unwanted images or check the application logs for more details."

We have two LMS 3.2 systems in a master-slave configuration. Both of which were recently upgraded to LMS 3.2 from 3.0. Software distribution is working as expected on the Slave system. It was working on the Master system before the upgrade to LMS 3.2 also.

I've checked all of the administrative settings I can think of and they match on both systems.

Am I missing something?

Thanks,

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: Problem with Software Distribution in LMS 3.2

Without debugs I can only guess but the symptoms you report could be caused by a few corrupted files.


You could try the following as it has solved similar situations.

Move SharedHelpACE.zip, SharedSwimACE.zip, and SharedSwimGSS.zip somewhere outside the CSCOpx directory.
The files can be found:
\CSCOpx\www\classpath\com\cisco\nm\xms\psu\pkgs\rme
As well as:
\CSCOpx\MDC\tomcat\webapps\rme\WEB-INF\lib\pkgs

Then restart the services:

net stop crmdmgtd
net start crmdmgtd


If this proves unsuccessful then replace the files in their original locations.
4 REPLIES
Silver

Re: Problem with Software Distribution in LMS 3.2

Hi,

Is this behavior occuring for all swim jobs or is it device specific? What verson of RME is installed?

Thanks

Community Member

Re: Problem with Software Distribution in LMS 3.2

It is all swim jobs...I can't get any software updates to work on the Master system.

We have RME 4.3.0

Silver

Re: Problem with Software Distribution in LMS 3.2

Without debugs I can only guess but the symptoms you report could be caused by a few corrupted files.


You could try the following as it has solved similar situations.

Move SharedHelpACE.zip, SharedSwimACE.zip, and SharedSwimGSS.zip somewhere outside the CSCOpx directory.
The files can be found:
\CSCOpx\www\classpath\com\cisco\nm\xms\psu\pkgs\rme
As well as:
\CSCOpx\MDC\tomcat\webapps\rme\WEB-INF\lib\pkgs

Then restart the services:

net stop crmdmgtd
net start crmdmgtd


If this proves unsuccessful then replace the files in their original locations.
Community Member

Re: Problem with Software Distribution in LMS 3.2

I missed this last post...

It worked! The Software Distribution process is now functioning.

Thanks...

490
Views
0
Helpful
4
Replies
CreatePlease to create content