Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Problems starting Topology services

I have been following the conversations regarding the various problems people are having starting topology services. I am have tried the recommended solutions and have had no luck.

I am running CW on a Solaris 10 sparc box. It is up and tells me that it is running correctly.

My client is also on a Solaris 10 sparc box.

I am running firefox 2.0. When I log in to CW, it tells me I have a supported browser.

When I click on Topology services I get a popup telling me I have chosen to open Topoligy_Services.jnlp a Java Web Start from http://myCWsvrBox:1741. It asks me what Firefox should do the this file.

I select Open with a long path name that is partially cut off at the end of the popup. What I can read of it indicates the jnlp file will be opened with something from the directory containing the jre1.5.0_13 version of Java I down loaded and installed on my client. I assume it is opening the jnlp file with the java program -- but I can't see the final letter(s), so I am not 100% sure.

Anyway, I clidk OK. I then get the Java running popup, and it then downloads another copy of the jnlp file. Then I get a widow the title of which is: "Topology Services (admin@ANIServer6.0-cwzone) (on cworks1). At the bottom of that widow it says initializing Applet."

Then I get a popup with an OK button saying, "vborb.jar installed successfully. Please launch Campus Applications again to work properly. Click OK to exit from the Plugin."

I click OK, then do a pdterm and a pdexec on the ANIServer, and restart my browser.

And the process is repeated. It is as though CW does not see that I have just done all that.

What gives?

I did notice 3 things.

1. In the script I used to install the java plugin on my client I found this line of code:


plugin/sparc/ns610/" "${NETSCAPE7_PATH}/plugins"

Which is wrong. This command will create a link from the library to a FILE called plugins int the ${NETSCAPE7_PATH} path.

I changed it to create the link in the firefox plugins directory to the file.

2. In the Topology_Services.jnlp, in the codebase variable it has http://<cwservername>:1741/CSCOcm/classpath . As I understand it this should be a real path. There is no such path in my installation. In fact there is no CSCOcm directory on the machine.

3. In the resources section of the jnlp file I see many lines with relative path notation (e.g., ../../JSP/CAMPUS/campus/res/cmvln-sign-1-3.jar

) According to the jnlp spec this is not legal. I may be misreading it or you may have you're own version. Still I thought I would mention it.

Could there be a problem in the JNLP file? Or am I not understanding how to read it.

As always, any help is greatly appreciated.


Dave Massie

Cisco Employee

Re: Problems starting Topology services

It sounds like the vbjorb.jar file is not being properly installed. You should have a vbjorb.jar file under JPI_PATH/lib/endorsed. This file should be 4451842 bytes.

Community Member

Re: Problems starting Topology services

have same issue ..could you please elaborate where exactly can find the vbjorb.jar to re installing. the step I should follow. thank you so much

Community Member

Re: Problems starting Topology services

Thanks. On which box is the vborb.jar file located -- the CW server? or the client machine I am running firefox from?

Also, how does JPI_PATH get set? I have no such environment varialbe on the machine I am running firefox from.

Thanks again.

Community Member

Re: Problems starting Topology services

I did check for the vbjorb.jar file and I found it in the



The file size matched what you gave me.

I tried it again and it still dosent work.


Cisco Employee

Re: Problems starting Topology services

There should be a /jpi.profile and/or /jpi.cshrc that is created with a required environment variables. Make sure this file is sourced (or that environment variables are otherwise set) before starting Firefox on the Solaris machine. Additionally (and it sounds like you may already have this) make sure that the symlink is correct under the Firefox plugins directory.

The vbjorb.jar file needs to be in the endorsed directory of the plug-in you are trying to use. Therefore, I assume you installed the plug-in you downloaded from CiscoWorks to /opt/sfw/lib, and that is the plug-in you are trying to use.

Community Member

Re: Problems starting Topology services

I opened a TAC case and the engineer told me that LMS 3.0.1 Topology services will NOT run on firefox.

I am in the process of getting a windows box running and will test with IE.

I will report back the rsults.


Cisco Employee

Re: Problems starting Topology services

Topology Services DOES run with Firefox. It is clearly documented in the installation guide:

Community Member

Re: Problems starting Topology services

I tried running topology services under IE on WinXP and it worked.

As for documentation showing Firefox will also work, I can only refer you to the Cisco engineers who respond to TAC cases who advised me the Firefox does NOT work with Topo Services.

The ticket number for this TAC case is 608423851.


Dave Massie

CreatePlease to create content