Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problems upgrading from LMS 3.0 to LMS 3.2 - the backup fails.

I'm upgrading from LMS 3.0 to LMS 3.2 on Solaris. I've met all of the prereq's, patches, etc. It keeps failing on the Backup...It claims I need 15 Gig for the backup. The backup directory I'm using (/opt/backup) has 35 Gig free, so that shouldn't be the issue.

Here is the error I'm seeing in the backup.log;

okcwsi:tail backup.log

tar: /var/adm/CSCOpx/files/rme/dcma/shadow/sw_images/cisco_configs/sw_images/cis

co_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_confi

gs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/c2950-i6q4l2-mz.121

-13.EA1c.bin: prefix is greater than 155

tar: /var/adm/CSCOpx/files/rme/dcma/shadow/sw_images/cisco_configs/sw_images/cis

co_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_confi

gs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/c1310-k9w7-tar.124-

10b.JDA2.tar: prefix is greater than 155

tar: /var/adm/CSCOpx/files/rme/dcma/shadow/sw_images/cisco_configs/sw_images/cis

co_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_confi

gs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/c2800nm-advsecurity

k9-mz.124-22.T1.bin: prefix is greater than 155

tar: /var/adm/CSCOpx/files/rme/dcma/shadow/sw_images/cisco_configs/sw_images/cis

co_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_confi

gs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/c3560-ipbase-mz.122

-53.SE2.bin: prefix is greater than 155

tar: /var/adm/CSCOpx/files/rme/dcma/shadow/sw_images/cisco_configs/sw_images/cis

co_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_confi

gs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/c7600-fpd-pkg.122-3

3.SRE1.pkg: prefix is greater than 155

tar: /var/adm/CSCOpx/files/rme/dcma/shadow/sw_images/cisco_configs/sw_images/cis

co_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_confi

gs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/c7600s72033-advente

rprisek9-mz.122-33.SRE1.bin: file name too long

tar: /var/adm/CSCOpx/files/rme/dcma/shadow/sw_images/cisco_configs/sw_images/cis

co_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/20100922075

156561-10.181.252.1.cfg: No such file or directory

ERROR(704): Cannot create or back up tar file. Backup cancelled. Verify that you

have write-access to this directory.

Backup failed: 2010/09/22 07:54:20

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

okcwsi:

I've tried this multiple times and each time it appears to fail on a different file/folder in the sw_images directory. This is our FTP directory where we store lots of IOS images for download. I've removed each of these files it errors out on and it keeps failing. I just removed all files from the sw_images folder and am trying the backup again now.

I'm attaching the backup.log which contains the failure information for each backup I've tried in the past two days.

My main question is...can I skip this backup somehow? I've got another LMS 3.0 system that I can export everything I need from. Skipping the backup isn't an option on the install/upgrade? It gives me the option to quit the install or try the backup again.

Thanks,

  • Network Management
Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Blue

Re: Problems upgrading from LMS 3.0 to LMS 3.2 - the backup fail

        You can skip the backup with a hidden option:

./setup.sh -b nobackup

However, I wouldn't feel comfortable until figuring out why the backup has been failing, ostensibly because tar is running into the 255-char limit (100 for the filename and 155 for the path), a result of the many iterations of the following:

sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/

2 REPLIES
Blue

Re: Problems upgrading from LMS 3.0 to LMS 3.2 - the backup fail

        You can skip the backup with a hidden option:

./setup.sh -b nobackup

However, I wouldn't feel comfortable until figuring out why the backup has been failing, ostensibly because tar is running into the 255-char limit (100 for the filename and 155 for the path), a result of the many iterations of the following:

sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/cisco_configs/sw_images/

New Member

Re: Problems upgrading from LMS 3.0 to LMS 3.2 - the backup fail

You nailed it...that recurring path was caused by some symbolic links that our unix admin created. It caused an endless loop, which hit that character limit.

I removed the symbolic links and the backup is working!

Thanks,

304
Views
0
Helpful
2
Replies
This widget could not be displayed.