Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with RME Process CTMJrmServer, ICServer & ConfigMgmtServer

I can not see the devices in the RME, the processes are shutdown. I rebooted the server but the process in the window Common Services -> Server -> Admin -> Process say:

CTMJrmServer Administrator has shut down this server

ConfigMgmtServer Administrator has shut down this server

ICServer Administrator has shut down this server

thank for your help

14 REPLIES
Cisco Employee

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

Please post the entire output of the pdshow command as well as the OS, and version of LMS.

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

The OS is Windows Server 2003 R2

Estandard Edition

SP1

Cisco Works LMS 2.5

output of pdshow of the server CW is attached

thank for your help

Cisco Employee

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

Hopefully it's not LMS 2.5 without patches. If it is, you really need to upgrade. It looks like the root of the problem is that CTMJrmServer is shutdown. Please post the CTMJrmServer.log. Was the hostname changed on this server after LMS was installed?

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

Thaks for your help

I attached the file CTMJrmServer.log, We dont change the name of the server, it is the same since we installed Cisco Works.

To Upgrade the LMS 2.5, What I have to do.

Cisco Employee

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

Please provide the output of netstat -a -n -o -b. To upgrade LMS, you first need to apply the LMS 2.5.1 update. Then you can apply the LMS 2.6 update, then you can download the various service packs on top of 2.6. The downloads can be found at http://www.cisco.com/kobayashi/sw-center/cw2000/lan-planner.shtml . The LMS 2.5.1 update is the LMS 2.5 December 2005 update.

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

I have to Upgrade LMS or I can wait for your nice commentaries before proceeding with the Upgrade

I attached the output of command netstat -a -n -o -b

Cisco Employee

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

I don't see a problem here. Please post the output of pdreg -l CTMJrmServer as well as the NMSROOT\lib\classpath\md.properties and the output of the set command.

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

good morning Joe

thank to much for your time.

Output pdreg -l CTMJrmServer

C:>pdreg -l CTMJrmServer

Process = CTMJrmServer

Path = D:\PROGRA~1\CSCOpx\bin\cwjava.exe

Flags = -cw D:\PROGRA~1\CSCOpx -cw:jre lib/jre -cp:p MDC/tomcat/w

ebapps/rme/WEB-INF/classes,MDC/tomcat/webapps/rme/WEB-INF/lib/ctm.jar,MDC/tomcat

/webapps/rme/WEB-INF/lib/log4j.jar com.cisco.nm.rmeng.jrmwrapper.server.CTMJobMa

nagerServer 01NI003

Startup = Started automatically at boot.

Dependencies = RMEDbMonitor jrm TomcatMonitor RMECSTMServer

md.properties

NMSROOT=D:/PROGRA~1/CSCOpx

PX_BINDIR=D:/PROGRA~1/CSCOpx/bin

PX_CGIDIR=D:/PROGRA~1/CSCOpx/cgi-bin

PX_LOGDIR=D:/PROGRA~1/CSCOpx/log

PX_TMPDIR=D:/PROGRA~1/CSCOpx/temp

PX_DATADIR=D:/PROGRA~1/CSCOpx/files

PX_DOCDIR=D:/PROGRA~1/CSCOpx/htdocs

PX_CLASSDIR=D:/PROGRA~1/CSCOpx/www/classpath

PX_CGIURL=/cgi-bin

PX_DOCURL=/

PX_CLASSURL=/CSCOnm/classpath

PX_SCLASSDIR=D:/PROGRA~1/CSCOpx/lib/classpath

PX_DATASTORE=DSN=rme

PX_CLASSPATH=D:/PROGRA~1/CSCOpx/lib/classpath;D:/PROGRA~1/CSCOpx/www/classpath;D:/PROGRA~1/CSCOpx/campus/www/classpath;D:/PROGRA~1/CSCOpx/campus/lib/classpath;D:/PROGRA~1/CSCOpx/campus/www/classpath;D:/PROGRA~1/CSCOpx/campus/lib/classpath

PX_APPDIR=D:/PROGRA~1/CSCOpx/objects

PX_CONFDIR=D:/PROGRA~1/CSCOpx/conf

PX_CTRBDIR=D:/PROGRA~1/CSCOpx/contrib

PX_HLPDIR=D:/PROGRA~1/CSCOpx/help

PX_LIBDIR=D:/PROGRA~1/CSCOpx/lib

PX_USER=casuser

PX_GROUP=casusers

PX_STOP_DELAY=3000

PX_SYS_CHECK=1

PX_OSA_PORT=42342

OSAGENT_PORT=42342

PX_HOST=01NI003

PX_FQDN=01NI003

ASANY=D:/PROGRA~1/CSCOpx/objects/db

SQLANY=D:/PROGRA~1/CSCOpx/objects/db

CORE_SECURE_PORT=443

CORE_NONSECURE_PORT=1741

PX_PROTOCOL=https

PX_PORT=443

PX_WEB_PORT=443

MAX_RAM=2048

MAX_SWAP=4096

MAX_CPU=1600

SYS_RAM=0

SYS_CPU=2992

SYS_SWAP=8192

PX_ANI_PORT=42344

thank you

Cisco Employee

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

Where is the output of the set command?

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

sorry,

D:\>set

AdminEmail=claudia.borge@telefonica.com.ni

ALLUSERSPROFILE=C:\Documents and Settings\All Users

APPDATA=C:\Documents and Settings\njt00874\Application Data

CLIENTNAME=CM02ITMALW

ClusterLog=C:\WINDOWS\Cluster\cluster.log

CommonProgramFiles=C:\Program Files\Common Files

COMPUTERNAME=01NI003

ComSpec=C:\WINDOWS\system32\cmd.exe

CWMIBDIR=D:\PROGRA~1\CSCOpx\objects\share\mibs

FP_NO_HOST_CHECK=NO

HOMEDRIVE=C:

HOMEPATH=\Documents and Settings\njt00874

LM_LICENSE_FILE=D:\PROGRA~1\CSCOpx\objects\smarts\conf\trial.dat.DFM

LOGONSERVER=\\01NI003

NUMBER_OF_PROCESSORS=2

OS=Windows_NT

Path=C:\Program Files\Windows Resource Kits\Tools\;D:\Perl\bin;D:\PROGRA~1\CSCOp

x\MDC\tomcat\bin;D:\PROGRA~1\CSCOpx\objects\smarts\lib;D:\PROGRA~1\CSCOpx\object

s\smarts\bin;D:\PROGRA~1\CSCOpx\campus\bin;D:\PROGRA~1\CSCOpx\MDC\Apache;D:\PROG

RA~1\CSCOpx\MDC\jre\bin;D:\PROGRA~1\CSCOpx\MDC\bin;D:\PROGRA~1\CSCOpx\lib\jre\bi

n\server;D:\PROGRA~1\CSCOpx\objects\db\win32;D:\PROGRA~1\CSCOpx\bin;C:\WINDOWS\s

ystem32;C:\WINDOWS;C:\WINDOWS\System32\Wbem

PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH

PROCESSOR_ARCHITECTURE=x86

PROCESSOR_IDENTIFIER=x86 Family 6 Model 15 Stepping 6, GenuineIntel

PROCESSOR_LEVEL=6

PROCESSOR_REVISION=0f06

ProgramFiles=C:\Program Files

PROMPT=$P$G

SESSIONNAME=RDP-Tcp#4

SM_BROKER=01NI003:9002

SM_HOME=D:\PROGRA~1\CSCOpx\objects\smarts

SM_RULESET_PATH=D:\PROGRA~1\CSCOpx\objects\smarts\rules

SM_SITEMOD=D:\PROGRA~1\CSCOpx\objects\smarts\local;D:\PROGRA~1\CSCOpx\objects\sm

arts

SM_SNMP_BUG_COMPATIBLE=1

SystemDrive=C:

SystemRoot=C:\WINDOWS

TEMP=C:\DOCUME~1\njt00874\LOCALS~1\Temp\2

TMP=C:\DOCUME~1\njt00874\LOCALS~1\Temp\2

USERDOMAIN=01NI003

USERNAME=njt00874

USERPROFILE=C:\Documents and Settings\njt00874

windir=C:\WINDOWS

Cisco Employee

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

I don't see anything obviously wrong here. I recommend you go ahead with the upgrade, and if the problem persists, then open a TAC service request. The problem appears to involve the CSTM subsystem, and debugging that is not very straight-forward.

Before doing the upgrade, set your global and per-user TEMP and TMP environment variables to something short like C:\WINDOWS\TEMP, and disable any anti-virus software.

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

ok Joe

Understood, i will install the updates and I comment on you then.

Thank you for your support

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

good nigth

I update the LMS to LMS 2.6 and no works, i cant see the devices in the reports

i attach the screen, please help me

thanks

Cisco Employee

Re: Problems with RME Process CTMJrmServer, ICServer & ConfigMgm

Initially, this looks like there is still a problem with jrm/CTMJrmServer. You will need to open a TAC service request so they can walk you through the debugging steps.

452
Views
0
Helpful
14
Replies
CreatePlease to create content