Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Proxy Setup LMS3.2 with Proxyless/transparent doesnt work

Hello,

For CCO connection we need a proxyless connection (transparent proxy without the need for Proxy-IP/Port/User, working IE settings are for Direct Internet connections) but LMS3.2 isnt able to provide this:

1. Proxy Server Setup doesnt accept "No Proxy" or empty Proxy fileds

2. SW Center Please => SW-Update brings after entering my CCO-Account:

ERROR: Unable to connect to Cisco.com. Please check D:/PROGRA~2/CSCOpx/log/psu.log file for details. Download operation cannot proceed.

=> check psu.log:

[ Mon Jan 25 17:48:30 CET 2010 ] INFO   [SecurityHandler : getCSProxyHost]  : No proxy Host configured
[ Mon Jan 25 17:48:30 CET 2010 ] INFO   [SecurityHandler : getCSProxyPort]  : No proxy port confgured
[ Mon Jan 25 17:48:35 CET 2010 ] INFO   [SecurityHandler : getCSProxyHost]  : No proxy Host configured

Is there any workarround to can use proxless connection for CCO-Access from LMS?

Steffen

3 REPLIES
Cisco Employee

Re: Proxy Setup LMS3.2 with Proxyless/transparent doesnt work

If the proxying is transparent to the client, then there is nothing you need to do in LMS.  The "No proxy" messages in the psu.log are informational.  Technically, you do not have a proxy, and that is fine.  If the transparent proxy is configured to intercept HTTP traffic, then things should just work.  LMS should be able to connect to Cisco.com just fine without proxy settings.  If you need to see why this isn't working, start a sniffer trace filtering on tcp/80 traffic to www.cisco.com.  Run the software update job, and the capture should show the problem.

Community Member

Re: Proxy Setup LMS3.2 with Proxyless/transparent doesnt work

Thx, yes a firewall has blocked this outside connection.

BTW., at the firewall log we found a lot of "LMS is calling Akamai":

Name:    a92-123-69-171.deploy.akamaitechnologies.com
Address:  92.123.69.171

What part of LMS-Application will access Akamai via HTTP(80)?

Cisco Employee

Re: Proxy Setup LMS3.2 with Proxyless/transparent doesnt work

I'm guessing this is happening via links provided by Cisco.com.  LMS will not contact Akamai directly.

484
Views
0
Helpful
3
Replies
CreatePlease to create content