Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QPM - cannot create new traffic rule...

I've recently rebuilt my QPM server and upgraded to the latest QPM version (4.1.4).  Initially everything went well, I created a couple of policies and a nested policy and deployed them.  However today when I go to create another policy I'm unable to enter any traffic rules.  I've turned on qpm debugging and I'm getting the following output in the window that pops up when I attempt to create a new rule:

Exception java.lang.NullPointerException occured in:

/qpm/servlet/com.cisco.nm.qpm.web.policy.policywizard.wizard.servlet.PolicyWizardControlServlet
Http Request Parameters:

primaryKey=77309411329
formKey=DefaultForm
direction=2
pageName=/qpm/policy/group/OutPoliciesReport.jsp
enableMode=null
wsn=com.cisco.nm.qpm.web.policy.policywizard.wizard.servlet.PolicyWizardControlServlet
currentDatabase=-10
wizardServletName=com.cisco.nm.qpm.web.policy.policywizard.wizard.servlet.PolicyWizardControlServlet
helpTagPrefix=trafficRuleGeneral
popupFlag=true

I get this error (with a different primary key) when I try to edit an existing rule as well.  I've also noticed that the nested policy I created has lost both its name and description, and when I try to rectify this nothing happens. 

Any ideas beyond rebuilding the installation yet again?

Cheers.

Everyone's tags (3)
2 REPLIES
Cisco Employee

Re: QPM - cannot create new traffic rule...

Rebuilding the installation is likely to wind you up in the same spot... with no new information.

What changed between the time you were able to create and deply the initial policy, and the appearance of this error?

I don't find any history on that particular error message, so I can't relate it to a bug yet. I think this one will need a TAC case opened to track it and get to resolution.

On the way there, if you haven't already, do the following to include some more information about the problem:

 

Step 1) Open a command prompt at ...\CSCOpx\MDC\qpm\bin enter the
command "setqpmloggermode -debug", for setting the trace level to
'debug' .

Step2) Wait 5 minutes to let the action take effect (the utility doesNOT
require restarting the services.

Step3) Now try the opersation that gives therror message.
If you see the same problem (I think you will), then continue Step4.

Step4) Open a command prompt at ...\CSCOpx\MDC\bin enter the command.
"mdcsupport". This will create the MDCSupportInformation.zip file at the
location 'CSCOpx\MDC\etc'.

Revert to 'info' trace level by entering the command "setqpmloggermode
-info". This is very important as QPM performance is slow when in
"Debug" mode.

Hope that helps!

New Member

Re: QPM - cannot create new traffic rule...

I have the exactly same problem on my QPM 4.1.4. Any recommenadtion?

249
Views
0
Helpful
2
Replies