Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Re-installing LMS 2.6 lead to an ANIServer connection issue

Hello,

I re-installed LMS 2.6 on a Windows Server for a customer, restored the previous backup and encountered the following problem when dealing with Campus (Topology) : "Cannot connect to ANI Server".

When I restore a backup on a new installation. Do the new ANI database password has to be the same as the previous one (the one in the backup) ?? Because I think the new password is different... and wondering if it could be the root cause.

Thanks for your Help !

3 REPLIES
Blue

Re: Re-installing LMS 2.6 lead to an ANIServer connection issue

Is the new server using the same hostname (DNS name) as the old one?

Find the "ANIServer.properties" file and verify the line reflects the new server's hostname:

AniName=ANIServer6.0-hostname

Community Member

Re: Re-installing LMS 2.6 lead to an ANIServer connection issue

Yes, the new server is using the same Hostname.

Is the ANIdb password important ? because I've a line in the CampusOGSServer.log log file saying DB connection refused :

java.lang.Exception: Error occurred in evaluating the sql Query java.sql.SQLException: Could not establish DB connectivity java.sql.SQLException: JZ006: Caught IOException: java.net.ConnectException: Connection refused: connect

Thanks for your help

Cedric.

Re: Re-installing LMS 2.6 lead to an ANIServer connection issue

Yes, this could be an issue; shut down daemon manager. For this, issue the following command in a DOS box:

net stop crmdmgtd

then run this script to set the database passwords for all databases:

NMSROOT\bin\perl.exe NMSROOT\bin\dbpasswd.pl all

restart the daemon manager with

net start crmdmgtd

142
Views
0
Helpful
3
Replies
CreatePlease to create content