Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Blue

RME 3.5 fails to delete stale device configs

RME config mgmt is set up to keep config for the last 30 days and the last 7 revisions. I just find out there're configs from as early as 2004 in /var/adm/CSCOpx/files/archive/config/###. I assume ### is the dbid of a device. There're as many as 224 (gasp!) running.cfg/slot1_running.cfg files in one directory. I think it's been suggested that it's not a good idea to delete CiscoWorks files from the UNIX CLI out right. But how could I otherwise clean up these stale configs "properly"? I have tried tuning down the level of config retention from 30 days to 15 days and 7 revs to 5 revs, respectively. That only seemed to make RME consume disk space faster, without deleting the real old configs.

4 REPLIES
Red

Re: RME 3.5 fails to delete stale device configs

(1)By default, the latest version of the running config is never purged even if it happens to violate the purge policy.

(2)Startup configs are never purged.

(3)Only files with ".cfg" extension are purged according to the purging policy. The ".dfc" and ".dfr" files are purged if there are no change audit records for them.

Go to RME -> Administration -> Change Audit -> Delete Change History

Select All Devices

Keep all the default values, and enter a Date Range of Older than 30 Days

Click on Next

Run Immidiately, then go ahead and schedule it to run weekly.

This will not delete the files, but next time a purge occurs, it should.

Blue

Re: RME 3.5 fails to delete stale device configs

Firs time I ran the Delete Change History (set to 31 days), it took two to three hours and MSIE returned a "this page cannot be displayed". I ran it again and got "None of the records in the database matches your filter criteria." within 10 mins. Does it mean it's safe for me to manually delete cfg files older than 30 days in /var/adm/CSCOpx/files/archive/config/###/?

Can I trigger a config purge right away by starting ConfigPurge under Server Config -> Admin -> Process Management -> Start Process? Crikey! Tried it anyway, it didn't do squat.

Blue

Re: RME 3.5 fails to delete stale device configs

Ran Delete Change History a third time, at Older than 60 days. Now it tells me it Successfully deleted 7198 records. Am going to fire up ConfigPurge again.

Now I'm seeing disk space freed up.

Blue

Re: RME 3.5 fails to delete stale device configs

Freed up 3.5GB eventually, ouch! Gotta run these steps more often.

114
Views
5
Helpful
4
Replies
CreatePlease login to create content