Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

RME 4.0 Device Update issue

I tried to do an update from LMS file system of several RME 4.0 packages and I got the following messages:

The Package(s) Selected for Install :

Number of Packages Selected for Install : 3

For Product(s) : Resource Manager Essentials

Install Invoked by user : admin

The Package(s) Selected for Install :

Cat3750, LibInventory, SharedInventoryCatSwitch

WARNING : Cat3750(3.0):Consistency check failed for base package SharedInventoryCatIOS

WARNING : SharedInventoryCatSwitch(2.1):Consistency check failed for base package LibInventory

No package(s) to install for : Resource Manager Essentials

It's a LMS 2.6 on Windows 2000 SP4.

I didn't have this kind of error before.

Do you have any idea ?

10 REPLIES

Re: RME 4.0 Device Update issue

if you update the pkgs from the local filesystem you have to take care of the correct sequence yourself, i.e in general you 'll need 3 seperate jobs: first the Libxxx pkgs, second the Sharedxxx and the last one the device pkgs.

This is time consuming because of the services restart but it works!

Community Member

Re: RME 4.0 Device Update issue

I tried LibInventory first and it worked.

But for SharedInventory, I got the same message as previously.

Do you know what means Consistency check failed for base package LibInventory ?

Silver

Re: RME 4.0 Device Update issue

Why yes I experienced this exact issue before and the clean up isn't nice since it points to a corrupted install. You can try deleting the packages and re-downloading them.

Community Member

Re: RME 4.0 Device Update issue

It could be a solution but I'm afraid to do it and not to be able to reinstall the package after deleting.

Cisco Employee

Re: RME 4.0 Device Update issue

This error means that you are missing dependent packages. The psu.log will list which packages are missing. If you are doing an update from the file system, it could be that you have not downloaded enough packages to satisfy the dependency tree.

Community Member

Re: RME 4.0 Device Update issue

You're certainly right.

In the psu.log, I have this message:

Dependent package[LibInventory] present in source location has lower version than needed

I've just installed the LibInventory package version 1.11.2.

In the readme file of the SharedInventory package, we need V1.11.1 of LibInventory which is less than I've installed.

Cisco Employee

Re: RME 4.0 Device Update issue

If a package requires a version less than the current version, that is fine. But something must be requiring LibInventory 1.11.2. Now that you've installed it. Note, the latest LibInventory is 1.11.4 which is part of the recent RME 4.0.6 update. If you upgrade to Common Services 3.0.6 and RME 4.0.6 you will have all the recent packages.

Community Member

Re: RME 4.0 Device Update issue

Thanks for reply.

Effectively, I planned to install these packages, but before that I will check them in my lab.

Community Member

Re: RME 4.0 Device Update issue

I looked for these patches on CCO.

I found RME.4.0.6 but I didn't find CS.3.0.6 in the CS patch list which is a pre-requisite for the RME patch.

Perhaps, I missed something ?

Community Member

Re: RME 4.0 Device Update issue

I found cs3.0.6 in the strong crypto zone of CCO.

219
Views
7
Helpful
10
Replies
CreatePlease to create content