Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RME can not upgrade IOS on Cisco 881

Hello!

RME 4.2.0 (from LMS 3.1) cannot upgrade IOS on Cisco 881 when SNMPv3 is configured on router. When I press "Distribute Images" in Device Center, I got:

Module Information - Not Available

Image Options - Failure

Storage Options - Failure

Errors - Failure

Software Image Management Notifications

SWIM1027: Error while fetching inventory information.

debug snmp packets (on 881 router)

Apr 23 11:48:52.788: SNMP: Packet received via UDP from x.x.x.x on Tunnel0

Apr 23 11:48:52.788: SNMP: Get request, reqid 578, errstat 0, erridx 0

ciscoMgmt.10.1.1.1.0 = NULL TYPE/VALUE

sysUpTime.0 = NULL TYPE/VALUE

Apr 23 11:48:52.796: SNMP: Response, reqid 578, errstat 0, erridx 0

ciscoMgmt.10.1.1.1.0 = NO_SUCH_OBJECT_EXCEPTION

sysUpTime.0 = 451328

Apr 23 11:48:52.804: SNMP: Packet sent via UDP to x.x.x.x

Apr 23 11:48:52.836: SNMP: Packet received via UDP from x.x.x.x on Tunnel0

Apr 23 11:48:52.836: SNMP: Get request, reqid 579, errstat 0, erridx 0

local.10.15.0 = NULL TYPE/VALUE

sysUpTime.0 = NULL TYPE/VALUE

Apr 23 11:48:52.844: SNMP: Response, reqid 579, errstat 0, erridx 0

local.10.15.0 = NO_SUCH_OBJECT_EXCEPTION

sysUpTime.0 = 451333

Apr 23 11:48:52.852: SNMP: Packet sent via UDP to x.x.x.x

I know that FlashMIB is missing on Cisco881. It looks like RME incorrectly handles responses where errstat=0, erridx=0.

Here what I see when I use SNMPv2c:

Apr 23 11:47:40.429: SNMP: Packet received via UDP from x.x.x.x on Tunnel0

Apr 23 11:47:40.429: SNMP: Get request, reqid 576, errstat 0, erridx 0

ciscoMgmt.10.1.1.1.0 = NULL TYPE/VALUE

sysUpTime.0 = NULL TYPE/VALUE

Apr 23 11:47:40.433: SNMP: Response, reqid 576, errstat 2, erridx 1

ciscoMgmt.10.1.1.1.0 = NULL TYPE/VALUE

sysUpTime.0 = NULL TYPE/VALUE

Apr 23 11:47:40.441: SNMP: Packet sent via UDP to x.x.x.x

Apr 23 11:47:40.477: SNMP: Packet received via UDP from x.x.x.x on Tunnel0

Apr 23 11:47:40.477: SNMP: Get request, reqid 577, errstat 0, erridx 0

local.10.15.0 = NULL TYPE/VALUE

sysUpTime.0 = NULL TYPE/VALUE

Apr 23 11:47:40.485: SNMP: Response, reqid 577, errstat 2, erridx 1

local.10.15.0 = NULL TYPE/VALUE

sysUpTime.0 = NULL TYPE/VALUE

Apr 23 11:47:40.489: SNMP: Packet sent via UDP to x.x.x.x

Apr 23 11:47:41.413: %SEC_LOGIN-5-LOGIN_SUCCESS: Login Success ...

As you can see, RME gets SNMP error "No Such Name" and then logs in via terminal.

Should I open TAC Case?

PS. I have LMS 3.1 for Windows.

4 REPLIES
Cisco Employee

Re: RME can not upgrade IOS on Cisco 881

It looks like you may have found a bug in RME. Just to confirm, please post the show run from this router.

New Member

Re: RME can not upgrade IOS on Cisco 881

This is config from a test router, but it behaves exactly as my production router:

881-test#sh run

Building configuration...

Current configuration : 1202 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 881-test

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

!

!

aaa session-id common

!

!

ip source-route

!

!

!

!

ip cef

ip domain name fuib.com

login on-failure log

login on-success log

!

no ipv6 cef

!

multilink bundle-name authenticated

!

!

username cisco privilege 15 secret 5 $1$7h4T$FCzkE3PM1eQV8GZGTEiGy/

!

!

!

archive

log config

hidekeys

!

!

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

no ip address

shutdown

duplex auto

speed auto

!

interface Vlan1

ip address 172.17.2.85 255.255.0.0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

ip access-list standard snmp-monitors

permit 172.17.2.80

!

snmp-server group otk-snmp-monitors-auth v3 auth access snmp-monitors

snmp-server ifindex persist

!

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

!

scheduler max-task-time 5000

end

PS. LMS IP is 172.17.2.80

Cisco Employee

Re: RME can not upgrade IOS on Cisco 881

Yep, this is a bug. If you open a TAC service request, I can provide a patch for you to try. Just have your engineer contact me directly.

Cisco Employee

Re: RME can not upgrade IOS on Cisco 881

I have since filed CSCsz41441 to track this.

578
Views
0
Helpful
4
Replies
CreatePlease to create content