Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RME Fails to Add Devices (DIServer Problem)

Hi There,

I have Cisco works SNMS version 1.5 installed on Windows 2000 server, I also have VMS version 2.3 installed on the same server and the VMS part is functioning perfectly.

The problem is related to RME inventory feature which doesn?t accept adding Cisco devices (routers or switches) and the devices' status doesnt get changed from pending to Managed; the RME version is 3.5. I'm receiving an error message related to DIServer when starting the server which I believe is related to my case, I tried to restart the system processes from under the Process Manager but this didn't help and I keep getting the error related to DiServer.exe

The DIServer.exe file exists under the Cisco works folder and I tried to run the executable manually thinking that it might help but unfortunately it did not. I also re-installed the RME again but this didn?t resolve my problem as well.

Attached are some snapshots which could be of help to understand my problem.

Please let me know what you think.

Best Regards,

Haitham

2 REPLIES
Silver

Re: RME Fails to Add Devices (DIServer Problem)

Hi Haitham,

i am not very familiar with VMS. But nevertheless i try to figure out the problem.

As far as i know the VMS uses Common Services 2.2 SP3 and RME 3.5.

SNMS 1.5 also uses Common Services 2.2 and RME 3.5.

But the versions used in both versions are not the same at all.

VMS uses RME IDU 12 and SNMS IDU Version 11.

VMS needs Java Plugin 1.4.1_2 while SNMS needs 5.0 or higher!

The standard Installation paths are "C:\Program Files\CSCOpx\"

most subdirs share the same name, but now has a inconsistent version handling!

The secreenshots you provide are showing the old LMS look until version 2.2. SNMS 1.5 has a different modern Interface!

In genereal i have serious doubts if these two software bundels should run on the same server!

The RME and the Common Services were insatlled twice with slighly different versions!!!

What Service pack do you run on W2K? SNMS 1.5 supports only SP2. SNSM 1.5.1 supports SP4!

Is it possible for you to open the SNMS Desktop in the Webbroser!?!

I add a screenshot of the SNMS 1.5 Webdesign.

Unfortunateley i can not 100% clarify this issue. But i hope to give you some valuable hints.

Best regards,

Frank

Cisco Employee

Re: RME Fails to Add Devices (DIServer Problem)

An application error of 0xc0000022 usually indicates a problem loading one of the required DLLs. This could be a permissions problem, or a DLL conflict. This can be caused by anti-virus software or even the Cisco Security Agent (if your policy is too restrictive).

As a first step, try temporarily disabling any anti-virus software and CSA (if installed), and see if the problem goes away. If it does, re-enable the AV software, and see if the problem returns. If you are able to isolate either AV or CSA, try tweaking the configurations so that DIServer properly starts.

If that does not pan out, I can provide an exhaustive list of DLLs used by DIServer, but it might be better to open a TAC Service Request as that may make things go more quickly.

170
Views
1
Helpful
2
Replies
CreatePlease login to create content